View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001022KdenliveUser Interfacepublic2009-07-07 12:492010-08-03 00:58
Assigned Toj-b-m 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001022: Using "History" with m2t files crashes the app
DescriptionUsing "History" with m2t HDV mpeg2 files crashes the app completely. It doesn't always crash it when using h.264 files, but with mpeg2, it's reproducible on my machine.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
Granjow (developer)
2009-07-07 13:52

Could you upload a short example MTS file? I've got some too, cannot reproduce, but perhaps they're h.264. ffmpeg -i doesn't know (Unable to find a suitable output format for 'Borretsch-00016.MTS').
Eugenia (reporter)
2009-07-07 22:05
edited on: 2009-07-07 22:06

I said M2T file, not MTS or M2TS. M2T is NOT the same as the AVCHD mts/m2ts. M2T is HDV, mpeg2. M2TS/MTS are AVCHD, mpeg4.
Download from here: [^] [^]

Granjow (developer)
2009-07-08 09:23

Ah, nice to know. Thanks.

Reproducing with a new project:
* Add both clips to project content
* Add both clips to timeline
* Click «Clean up» in the History (first entry). Multiple undo (Ctrl+Z) won't crash kdenlive here.

Seems like a kdenlive problem, not MLT.
Granjow (developer)
2009-07-08 10:02

Cannot reproduce when running with valgrind :(
Eugenia (reporter)
2009-07-08 10:09

No, you have to actually DO some video editing before you can reproduce it. Add a few plugins, remove them. Add some others. Then cut the clips, split the A+V, add some transitions. Overall, have about 20-25 items in your history. THEN, click on an item in the History, about 6-7 levels above the last one. It crashes here.
Granjow (developer)
2009-07-08 10:32

No, if you only follow the steps I noted above then kdenlive crashes here. I tried to get some more information about the crash by running kdenlive in valgrind but there it wasn't reproducable. I wonder whether it prevents kdenlive from crashing, also tried to split audio/video now and still no crash. Output however:

==5554== Invalid read of size 4
==5554== at 0x80FC40A: DocClipBase::markerComment(GenTime) (qlist.h:91)
==5554== by 0x80B9F13: Monitor::checkOverlay() (monitor.cpp:480)
==5554== by 0x80BA2CB: Monitor::rendererStopped(int) (monitor.cpp:593)
==5554== by 0x80BA765: Monitor::qt_metacall(QMetaObject::Call, int, void**) (monitor.moc:241)
==5554== by 0x4CC27EA: QMetaCallEvent::placeMetaCall(QObject*) (in /usr/lib/
==5554== by 0x4CC428F: QObject::event(QEvent*) (in /usr/lib/
==5554== by 0x4F96CAF: QWidget::event(QEvent*) (in /usr/lib/
==5554== by 0x4F407BB: QApplicationPrivate::notify_helper(QObject*, QEvent*) (in /usr/lib/
==5554== by 0x4F48BB1: QApplication::notify(QObject*, QEvent*) (in /usr/lib/
==5554== by 0x42BB5EC: KApplication::notify(QObject*, QEvent*) (in /usr/lib/
==5554== by 0x4CB3A2A: QCoreApplication::notifyInternal(QObject*, QEvent*) (in /usr/lib/
==5554== by 0x4CB4684: QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (in /usr/lib/
==5554== Address 0x77a9120 is 32 bytes inside a block of size 84 free'd
==5554== at 0x40249DA: operator delete(void*) (vg_replace_malloc.c:342)
==5554== by 0x807C1E1: AddClipCommand::undo() (addclipcommand.cpp:42)
==5554== by 0x55EE2D7: QUndoCommand::undo() (in /usr/lib/
==5554== by 0x55EF8F9: QUndoStack::setIndex(int) (in /usr/lib/
==5554== by 0x55F0B56: (within /usr/lib/
==5554== by 0x55F0FB6: (within /usr/lib/
==5554== by 0x4CC9B97: QMetaObject::activate(QObject*, int, int, void**) (in /usr/lib/
==5554== by 0x4CCA821: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (in /usr/lib/
==5554== by 0x550D278: QItemSelectionModel::currentChanged(QModelIndex const&, QModelIndex const&) (in /usr/lib/
==5554== by 0x550D41C: QItemSelectionModel::setCurrentIndex(QModelIndex const&, QFlags<QItemSelectionModel::SelectionFlag>) (in /usr/lib/
==5554== by 0x54BEDE5: QAbstractItemView::mousePressEvent(QMouseEvent*) (in /usr/lib/
==5554== by 0x4F974B5: QWidget::event(QEvent*) (in /usr/lib/
j-b-m (administrator)
2009-07-19 00:09

Might be fixed by commit 3731, please test
Granjow (developer)
2009-07-19 10:48

Seems to work here. Eugenia?
Eugenia (reporter)
2009-07-19 10:56

Sorry, without an updated ubuntu binary, I can't test.
Granjow (developer)
2009-07-19 10:59 [^] :)
Eugenia (reporter)
2009-07-19 11:08

No, I refuse to compile from source, sorry. After years with Gentoo, Slackware and Arch, I am well-situated in a dev-environment-less Ubuntu installation, and I refuse to build anything from source. If it doesn't exist as a binary, it doesn't exist for me. It's a matter of principle, not a lack of skill.

- Issue History
Date Modified Username Field Change
2009-07-07 12:49 Eugenia New Issue
2009-07-07 12:49 Eugenia Build/Install Method => 3rd party package
2009-07-07 13:52 Granjow Note Added: 0003617
2009-07-07 13:52 Granjow Status new => feedback
2009-07-07 22:05 Eugenia Note Added: 0003625
2009-07-07 22:06 Eugenia Note Edited: 0003625 View Revisions
2009-07-08 09:23 Granjow Note Added: 0003647
2009-07-08 09:23 Granjow Status feedback => acknowledged
2009-07-08 10:02 Granjow Note Added: 0003649
2009-07-08 10:02 Granjow Category MLT => User Interface
2009-07-08 10:09 Eugenia Note Added: 0003650
2009-07-08 10:32 Granjow Note Added: 0003651
2009-07-19 00:09 j-b-m Note Added: 0003675
2009-07-19 00:09 j-b-m Assigned To => j-b-m
2009-07-19 00:09 j-b-m Status acknowledged => feedback
2009-07-19 10:48 Granjow Note Added: 0003678
2009-07-19 10:56 Eugenia Note Added: 0003679
2009-07-19 10:59 Granjow Note Added: 0003680
2009-07-19 11:08 Eugenia Note Added: 0003681
2010-08-03 00:58 ttill Status feedback => resolved
2010-08-03 00:58 ttill Resolution open => fixed
2010-08-03 00:58 ttill Fixed in Version => 0.7.6
2010-08-03 00:58 ttill Status resolved => closed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker