View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001718KdenliveRenderingpublic2010-07-30 22:222013-01-28 19:51
Assigned Toptitmain 
Platform64 BitOSUbuntuOS Version10.04
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0001718: When rendering "Selected Zone," it only renders about 60% of it, then plays an earlier section for the rest.
Description   The title basically says it all. The weird thing is that I rendered one video and at the 60% point it played the beginning of the project. Then, I moved the left side of the selection earlier and when I rendered it was a little later in the clip, though still early on. I'm going to try rendering in different ways and see if I can find more of a pattern.

Steps To Reproduce - Open Project
 - Select area in the middle of the project
 - Render "Selected Zone"
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
lexen (reporter)
2010-07-31 01:27

I have been messing with it a little bit and it appears as if the 60% I said earlier was arbitrary. It happened when it got to a specific section of one of the clips. The good news is that it gave me an Error Log:

** (:4460): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
** (:4460): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
** (:4460): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
** (:4460): CRITICAL **: giop_thread_request_push: assertion `tdata != NULL' failed
** ERROR:poa.c:1968:PortableServer_POA_destroy: assertion failed: (done || !wait_for_completion)

   I then moved the selected zone to after that frame and it rendered for about 3 seconds then when a sound effect was supposed to play it kicked back to the very beginning but the audio was playing in a really high pitch. Then I moved the starting point to one frame after the audio clip started and it just rendered the beginning of the clip with a low pitch this time. Next I selected right after that clip got done and it worked.

   I then rendered the whole project and then the clip messed up again at that same sound effect and after it all the audio played in a higher pitch. I removed that sound effect (ogg) and it worked.
ttill (developer)
2010-08-03 11:58

So it only happens in combination with a ogg sound file?
lexen (reporter)
2010-08-03 13:45

Yeah, it looks that way. I'll mess with it more to see if that is always the case.
ptitmain (developer)
2012-12-14 22:29

I think that this bug is now solved in the version > 0.9 ok kdenlive. I often use ogg files and render a limited selection of the project and all is going fine. Thank your for reporting the bug !

- Issue History
Date Modified Username Field Change
2010-07-30 22:22 lexen New Issue
2010-07-31 01:27 lexen Note Added: 0005426
2010-08-03 11:58 ttill Note Added: 0005463
2010-08-03 11:58 ttill Status new => feedback
2010-08-03 13:45 lexen Note Added: 0005464
2010-08-03 13:45 lexen Status feedback => new
2012-12-14 22:29 ptitmain Note Added: 0008779
2012-12-14 22:29 ptitmain Status new => resolved
2012-12-14 22:29 ptitmain Fixed in Version => 0.9.2
2012-12-14 22:29 ptitmain Resolution open => fixed
2012-12-14 22:29 ptitmain Assigned To => ptitmain
2013-01-28 19:49 j-b-m Fixed in Version 0.9.2 => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker