View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001791KdenliveMLTpublic2010-09-01 11:102010-09-22 09:38
Assigned To 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001791: Severe Audio stuttering issues, also in rendered file
DescriptionMaybe this is an ffmpeg bug?

Audio of rendered result is unusable.

To reproduce:
1. Download the totally hig-quality sample video below (should be uploaded in ca. 1 h) [^] (94 MB)
2. Create a new project (Video is 720p, 24 fps)
3. Add it to the timeline and play the file from the beginning.
   The sound from the wooden stick at 03:12 sounds perfectly fine.
4. Now crop about 3.5 seconds from the start of the clip.
   Play the project from the beginning. At 3:12 the sound will echo multiple times.
5. Render to a file. Same problem.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
sterna (reporter)
2010-09-02 10:50
edited on: 2010-09-02 10:51

I was able to work around a very similar issue by manually remuxing the quicktime files created by a Canon EOS into avi files using ffmpeg like this:

for f in *mov ; do ffmpeg -i $f -vcodec copy -acodec copy $f.avi ; done

After this, my audio sounds accurate (though I have yet to render a clip that actually plays OK with most players - only mplayer does a decent job currently).

It may be worth pointing out that the audio thumbnails have been accurate all the time, but playback and rendering both output stretches of audio repeated, then skip some.

ttill (developer)
2010-09-06 22:28

Cannot reproduce, or I do not hear it ;)
Does this also happen when playing with "in" set in melt?
Or when seeking in ffplay?

Anyways how do you crop 3.5 seconds and then listen to 3:12?
Granjow (developer)
2010-09-13 18:37

I put the clip to the beginning of the timeline, press Play. When it reaches about 4 or 5 seconds I click to 3:09 (09 = frame 9, not 0.09 seconds) so the cursor jumps to 3:09 and continues playing from there. Reverbs like in a big cave.

When resizing the beginning by dragging it to 3:09, placing the cursor before the start of the clip, and pressing play again: reverbs again.

Audible as well with
melt audio-stuttering-sample.avi in=84
Granjow (developer)
2010-09-18 17:19

@ttill, can you reproduce it now?
ttill (developer)
2010-09-18 18:44

sorry, forgot about that report.
I did also notice it now.
However playing it like this "ffplay audio-suttering-sample.mp4 -ss 3" does not have audio at the problematic scene at all. Not sure if this is related to ffplay's seeking capabilities though.
ddennedy (developer)
2010-09-22 05:40

I am not able to download the entire file. Only shows about 1sec when loaded. Tried downloading 3 times, third time with wget.
Granjow (developer)
2010-09-22 09:38

Tried as well right before, no problem.
98495052 1. Sep 11:26 audio-stuttering-sample.avi
md5sum: 3db705d49911b9e8f2b269775254a49a

- Issue History
Date Modified Username Field Change
2010-09-01 11:10 Granjow New Issue
2010-09-02 10:50 sterna Note Added: 0005750
2010-09-02 10:51 sterna Note Edited: 0005750 View Revisions
2010-09-06 22:28 ttill Note Added: 0005802
2010-09-06 22:28 ttill Status new => feedback
2010-09-13 18:37 Granjow Note Added: 0005831
2010-09-13 18:37 Granjow Status feedback => new
2010-09-18 17:19 Granjow Note Added: 0005854
2010-09-18 18:44 ttill Note Added: 0005855
2010-09-22 05:40 ddennedy Note Added: 0005881
2010-09-22 09:38 Granjow Note Added: 0005894

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker