View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001803KdenliveUser Interfacepublic2010-09-05 11:552011-05-14 18:42
Assigned Toj-b-m 
Platform32 bit intel and alikeOSOpenSUSEOS Version11.0
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001803: Monitors controls disappear when detached
DescriptionMonitors controls disappear when you detach one of them from the main guy. Not only playback buttons but also window controll. Attached a screenshot of the problem.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon kdenlive_windows.png [^] (603,824 bytes) 2010-09-05 11:55
png file icon Screenshot2.png [^] (309,170 bytes) 2010-09-06 16:35

- Relationships

-  Notes
j-b-m (administrator)
2010-09-05 14:58

This bug has been there for a long time. Most widget become unusable when undocked. I spent some time trying to understand but couldn't find a reasonable explanation. My guess is that it's a Qt bug but not sure...

Since I have no clue about that one, it probably won't be fixed for the 0.7.8 release, sorry...
opensourcecat (reporter)
2010-09-06 01:12

Oh. I found it just because i wanted to try my new two monitor setup :(
tidris769 (reporter)
2010-09-06 06:16

For what it's worth, I don't see that problem happen on my 32-bit ubuntu 9.10 system.
j-b-m (administrator)
2010-09-06 08:09

sure, it'interesting. Can you give us more details:
Qt version,KDE version, graphic card and driver, which desktop environment (gnome,KDE), Desktop effects enabled?

that might help to find where the bug is...
tidris769 (reporter)
2010-09-06 16:35
edited on: 2010-09-06 16:37

I run ubuntu 9.10 (karmic), gnome 2.28.1 desktop, kde 4.3.2, ubuntu Visual Effects set to None, NVIDIA GeForce 8600M GT, NVIDIA driver 256.44.

I am able to detach the Clip Monitor and Project Monitor from the main kdenlive window and all the widgets at the bottom of the monitor windows remain visible and functional. I am using kdenlive svn 4852 at the moment.

One problem I did notice is that the image widget in detached monitor windows doesn't always get repainted when it should, but the control widgets at the bottom of the detached window do remain visible and work normally at all times.

tidris769 (reporter)
2010-09-06 16:36

See attached Screenshot2.png.
j-b-m (administrator)
2010-09-07 22:58

I am using ubuntu 10.4 (lucid), KDE session (KDE 4.5.1 + Qt 4.7 rc1), NVIDIA 7600 GS, driver 256.52, dual monitor setup.

I previously used Nvidia driver 185.x, upgrading it did not change anything.
Also tried to change the window manager to use Metacity, but bug is still here.
Using only one monitor didn't solve the issue.

Would be interesting to have system infos for other users, and if they encounter this bug or not because I have no idea where the problem is.
opensourcecat (reporter)
2010-09-07 23:06

I have KDE 4.5.1 and Qt 4.6.3. I'm going to upgrade to latest Qt provided from openSUSE repos tonight to see what changes.

nVidia drivers 256.53.
ttill (developer)
2010-09-08 08:15
edited on: 2010-09-08 08:16

I have the same problems here on Archlinux. KDE 4.5.1, Qt 4.6.3 but not using the KDE environment, rather something based on Openbox. Problem exists with nvidia as well as nouveau driver.
Strange thing is in other apps also based on KDE + Qt it works. (Dolphin, Krita)

@jb: commit 4680 does not mean much improvement for me. An example: Detach project tree, attach it again, add clip, detach -> not drawn properly.

woogs (reporter)
2011-04-26 19:37

On ArchLinux 64-bit, using AMD Catalyst driver, kdenlive-svn and qt-git, getting same behaviour (detached monitors don't render controls). If this is a Qt bug, it looks like upstream is unaware.
woogs (reporter)
2011-04-28 23:24
edited on: 2011-04-29 00:38

Starting kdenlive 0.8 in console with Qt 4.7.2, I notice a stream of error messages whenever I detach the clip or project monitor:

X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 62 (X_CopyArea)
  Resource id: 0x6c10eb6

That error simply repeats many times - I'm assuming it's repeating because of multiple drag/drop events triggering while I drag the freshly-detached window.

After poking through Google, I found this link: [^]

Seemingly indicating the problem was identified in Qt4 and solved over half a decade ago. Digging further, I also found this: [^]

Which is much more recent, and may also be related.

woogs (reporter)
2011-05-14 18:42

I was able to fix this problem for myself, using KDE as a desktop, by disabling all desktop effects, and switching my theme from Oxygen back to Plastick.

- Issue History
Date Modified Username Field Change
2010-09-05 11:55 opensourcecat New Issue
2010-09-05 11:55 opensourcecat File Added: kdenlive_windows.png
2010-09-05 14:58 j-b-m Note Added: 0005781
2010-09-05 14:58 j-b-m Assigned To => j-b-m
2010-09-05 14:58 j-b-m Status new => acknowledged
2010-09-06 01:12 opensourcecat Note Added: 0005788
2010-09-06 06:16 tidris769 Note Added: 0005789
2010-09-06 08:09 j-b-m Note Added: 0005790
2010-09-06 16:35 tidris769 Note Added: 0005793
2010-09-06 16:35 tidris769 File Added: Screenshot2.png
2010-09-06 16:36 tidris769 Note Added: 0005794
2010-09-06 16:37 tidris769 Note Edited: 0005793 View Revisions
2010-09-06 16:37 tidris769 Note Edited: 0005793 View Revisions
2010-09-07 22:58 j-b-m Note Added: 0005805
2010-09-07 23:06 opensourcecat Note Added: 0005806
2010-09-08 08:15 ttill Note Added: 0005807
2010-09-08 08:16 ttill Note Edited: 0005807 View Revisions
2011-04-26 19:37 woogs Note Added: 0006668
2011-04-28 23:24 woogs Note Added: 0006679
2011-04-29 00:38 woogs Note Edited: 0006679 View Revisions
2011-05-14 18:42 woogs Note Added: 0006715

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker