View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002005KdenliveFile Loadingpublic2011-02-07 16:002013-01-28 19:51
Assigned Toj-b-m 
Platformx86_64OSFedoraOS Version14
Product Version0.7.7.1 
Target VersionFixed in Version0.9.4 
Summary0002005: Clips randomly reshuffle when loading
DescriptionIt seems many times after saving and then reloading, missing clip error is presented and then clips are reshuffled.
Additional Information

I am trying to use kdenline to edit a wedding video. I had two cameras running, one Sony HD CX110B, and a another no-name SD camera. My first pass simply put the HD source as track 1 and the SD source as track 2. That worked well. Then I shifted the tracks to insert a new track with the SD pan & zoom. As the first track, so I could see both views during parts of the video. My first render well, but I forgot a composite on a 10 second clip.

I reloaded the video, made that slight change and rerendered. During playback, I notice the most of the clips on the second track had been shifted, so the composite modes did not match up. I reloaded the project, and sure enough everything on that track was shifted after the first few clips.

I then decided it would be better to redo the project from scratch (using the same timings) where I use the SD as the first track and HD as the second track, and no third track. This time I did not render immediately after saving, but had to come back to do that later. When I reloaded the project it gave me an error about missing clips. When I looked everything on the second track was shifted around. I manually moved everything back and place. But then when previewing, I found the PAN & SCAN for the SD track was being applied to the HD track... I could not figure out a way to fix that. So I exited the program, restarted and reloaded. Again most of the clips where shifted. In fact this time most of the HD video tracks where moved down to the end of the audio track!

I'm not sure what is going on, but I guessing it is some sort of parsing problem for the XML save file. I then examining the xml file to see if any of the filters were applied to the wrong track, but all of them were labeled for track 0.

I notice the x86_64 MTL built in rpmfusion is 0.5.4-2, which is older than what the website recommends using. Perhaps that is part of the problem?
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
docbill (reporter)
2011-02-08 17:04

I think this might be related to having lots of transition effects, where the transition effects do not exactly line-up with the video clips.

I redid my project with a single transition effect apply for the whole duration of the video and this problem did not occur once.
ttill (developer)
2011-03-04 23:28

Could you please retest with 0.7.8?
vpinon (administrator)
2011-11-09 08:18


Working in 0.8.2 with HD clips, I am not sure my problem is exactly related, but symptoms would fit under a similar title :

Editing 2 days full-time, few times (let's say 8?) I was feeling kdenlive becoming less responsive, so saved, closed Kdenlive and reopened my project. But 3 times (not always) I got misaligned elements, shifted by less than 1sec : clip slices that had clear space aside on the timeline, and/or effects (Composite, dissolve) that don't fall anymore in front of their respective clips.

I will apply the latest bugfix git commits, but to my understanding this problem is not directly adressed by the patches...
I go on editing to try to isolate better the problem, hoping to get it solved for next release ;-)
eddrog (developer)
2012-11-27 13:18

Some feedback or action here?
vpinon (administrator)
2012-11-27 19:20

Sorry, for forgetting the ticket, it doesn't occur anymore for long.

- Issue History
Date Modified Username Field Change
2011-02-07 16:00 docbill New Issue
2011-02-08 17:04 docbill Note Added: 0006402
2011-03-04 23:28 ttill Note Added: 0006536
2011-03-04 23:28 ttill Status new => feedback
2011-11-09 08:18 vpinon Note Added: 0007528
2012-11-27 13:18 eddrog Note Added: 0008669
2012-11-27 19:20 vpinon Note Added: 0008671
2012-11-27 19:20 vpinon Status feedback => resolved
2012-11-27 19:20 vpinon Fixed in Version => 0.9.2
2012-11-27 19:20 vpinon Resolution open => fixed
2012-11-27 19:20 vpinon Assigned To => j-b-m
2013-01-28 19:49 j-b-m Fixed in Version 0.9.2 => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker