View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002130KdenliveCapturepublic2011-05-18 22:462011-06-15 19:17
Assigned Toj-b-m 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product Version0.8 
Target VersionFixed in Version 
Summary0002130: Decklink Capture fails to add captured footage to project
DescriptionI have a Decklink HD Extreme 3D. The kdenlive blackmagic capture module shows incoming video correctly and appears to capture video and audio raw files. However it fails to pull them into the project when the auto-add option is set, and refuses to do so when trying to import it manually as well.

As a side note, the captured video is gi-normous. Compressing captured video to something like DNxHD, MJPEG or something similar.
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
FishB8 (reporter)
2011-05-21 19:24

Checking bug status I saw the last part got cut off. Should read:

As a side note, the captured video is gi-normous. Compressing captured video to something like DNxHD, MJPEG or something similar would be preferred to a raw video dump.
j-b-m (administrator)
2011-05-21 20:08

Yes, this is a known issue. The captured video can be converted using FFmpeg to then be imported in Kdenlive.

In fact, Decklink capture is currently more a proof of concept. I am about to rewrite it to use MLT for the job, which should allow to capture directly to a standard format, but need some more time for it.
FishB8 (reporter)
2011-05-22 04:31

Don't know if it is of much interest, but you may find this code to be of some use: [^]

Let me know if I can provide any sort of testing.

Slightly off-topic, but related, it would be nice if there was support for ancillary timecode data when using SDI input / outputs.
j-b-m (administrator)
2011-05-29 13:00
edited on: 2011-05-29 13:01

I just committed a rewrite of the video4linux and decklink capture. Decklink capture now uses MLT (requires latest git) and can encode to whatever format you want.

I would be interested to have some feedback if some of you can test the latest svn. Kdenlive now also informs the user about dropped frames while capturing.

Currently, having the live preview while capturing results in lots of dropped frames, I need to improve that, but I added a checkbox to disable preview while capturing, which gives better results. I have a 4 years old dual core and still experience some dropped frames on HD encoding, would be interested to hear about performance with better systems...

FishB8 (reporter)
2011-06-01 06:03

Built git sources today for MLT and Kdenlive.

Gentoo System
Kernel 2.6.39
Decklink Lib/Module Package 8.0.1_rc4 (Needs small patch to compile against kernel 2.6.39)

No issues building. Will hopefully have time to actually test it tomorrow.

BTW: SDK version 8.0 has been released. Not sure if anything changed, but you may want to update your decklink include files in git. (And possibly MLT as well)
FishB8 (reporter)
2011-06-01 18:55

Tried it out capturing some short clips.

- No frames were dropped using the default MPEG2 capture format. Although I haven't captured anything over a minute yet.
- Tried creating a MJPEG capture profile with no such luck.
- Buttons in the capture window don't update correctly (record button stays "on")
- Project profile and capture format were both 720p@60. Captured from HDMI video and analog audio.
- Capture display drawing gets gross when resizing. (doesn't redraw the space correctly)
- Scoping directly from the record source works great!
- Doesn't deal very gracefully with situations where the signal being fed to the input does not match the project profile. (Not sure if the blackmagic API provides a mean to deal with that)

Let me know if I can provide any more relevant info.
j-b-m (administrator)
2011-06-03 19:37

Some of the issues were fixed in MLT and Kdenlive's latest versions.

- You said capture worked without dropped frames, but did you have the live preview in record monitor? If yes, can you please tell us what is your PC's processor / memory
- I also tried several other profiles without success, this is still a question
-Buttons should work correctly now
-If the profile does not match, you should get an error message in Kdenlive's status bar
-Dan fixed a freeze when trying to capture when no device was connected to the Decklink
FishB8 (reporter)
2011-06-06 19:02

Yes, I did have live preview in the record monitor (approx. 1 or 2 fps while recording)

Here's the stats on the box being used with the decklink:

MoBo: Asus Sabertooth X58

CPU : Intel i7 Quad Core

vendor_id : GenuineIntel
cpu family : 6
model : 26
model name : Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz
stepping : 5
cpu MHz : 3067.000
cache size : 8192 KB
physical id : 0
siblings : 8
core id : 3
cpu cores : 4
apicid : 7
initial apicid : 7
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida dts tpr_shadow vnmi flexpriority ept vpid
bogomips : 6761.00
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Video Card : GeForce 8400GS

03:00.0 VGA compatible controller: nVidia Corporation Device 10c3 (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Corp. Device 1302
        Flags: bus master, fast devsel, latency 0, IRQ 24
        Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ce000000 (64-bit, prefetchable) [size=32M]
        I/O ports at cc00 [size=128]
        [virtual] Expansion ROM at fbb00000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nvidia
        Kernel modules: nvidia

The blackmagic card is a Decklink HD Extreme 3D

04:00.0 Multimedia video controller: Blackmagic Design Device a121
        Subsystem: Blackmagic Design Device a121
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at fbc00000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [40] Power Management version 3
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [60] Express Endpoint, MSI 00
        Kernel driver in use: blackmagic_driver
        Kernel modules: blackmagic

FFMPEG was build with VDPAU support if that makes any difference. (I think that accelerates MPEG2 and H264 decoding)

ffmpeg version 0.7-rc1, Copyright (c) 2000-2011 the FFmpeg developers
  built on May 4 2011 11:04:37 with gcc 4.5.2
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc --disable-static --enable-gpl --enable-version3 --enable-postproc --enable-avfilter --disable-stripping --disable-debug --disable-doc --enable-libmp3lame --enable-libvo-aacenc --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-libfaac --enable-nonfree --enable-libdc1394 --disable-indev=v4l --disable-indev=v4l2 --disable-indev=oss --enable-x11grab --disable-outdev=oss --enable-frei0r --enable-libfreetype --enable-pthreads --enable-libdirac --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libvpx --enable-libopenjpeg --disable-altivec --disable-avx --cpu=host --enable-hardcoded-tables
  libavutil 50. 40. 1 / 50. 40. 1
  libavcodec 52.120. 0 / 52.120. 0
  libavformat 52.108. 0 / 52.108. 0
  libavdevice 52. 4. 0 / 52. 4. 0
  libavfilter 1. 77. 0 / 1. 77. 0
  libswscale 0. 13. 0 / 0. 13. 0
  libpostproc 51. 2. 0 / 51. 2. 0
FishB8 (reporter)
2011-06-06 19:55

I tested the latest git sources where the capture code was move from internal to kdenlive to MLT, and now I have lots of frames reported being dropped. Also get an odd flash of white once or twice when first starting playback or recording.

Audio levels from the decklink don't show up in the metering when playing or recording. Decklink config interface also needs to provide access to showing which channels to record from when there are more than 2 channels in the HDMI or SDI feeds.
FishB8 (reporter)
2011-06-15 19:17

Built latest git sources.

mlt: v0.7.2-118-g66f934d
kdenlive: 0.8.0-123-g8754676

Recording now works pretty much the same as it did before moving capture code to mlt. Probably a little better, as the display update while recording are a little more frequent. No more dropped frames, no flashing white frames. (although the vector scope "flashes" every now and then while previewing the capture source)

Still no audio metering from decklink sources during preview or capture.

Still can't get a MJPEG capture profile to work. Here's what I have right now for the profile:

vcodec=mjpeg q=1 pix_fmt=rgb24 acodec=pcm_s16le ac=2 ar=48000 f=avi threads=%threads

also tried changing f=nut, no difference.

- Issue History
Date Modified Username Field Change
2011-05-18 22:46 FishB8 New Issue
2011-05-21 19:24 FishB8 Note Added: 0006730
2011-05-21 20:08 j-b-m Note Added: 0006731
2011-05-21 20:08 j-b-m Assigned To => j-b-m
2011-05-21 20:08 j-b-m Status new => acknowledged
2011-05-22 04:31 FishB8 Note Added: 0006733
2011-05-29 13:00 j-b-m Note Added: 0006764
2011-05-29 13:01 j-b-m Note Edited: 0006764 View Revisions
2011-06-01 06:03 FishB8 Note Added: 0006795
2011-06-01 18:55 FishB8 Note Added: 0006796
2011-06-03 19:37 j-b-m Note Added: 0006803
2011-06-06 19:02 FishB8 Note Added: 0006815
2011-06-06 19:55 FishB8 Note Added: 0006816
2011-06-15 19:17 FishB8 Note Added: 0006899

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker