View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002146KdenliveUser Interfacepublic2011-05-27 18:182011-10-02 08:13
Assigned Toj-b-m 
PlatformSorcererOSLinuxOS Version2.6.38.4
Product Version0.8 
Target VersionFixed in Version 
Summary0002146: Progress indicator stays at 0% when rendering mpeg-2
DescriptionProgress indicator stays at 0% when rendering mpeg-2 output. The file is actually rendering, and works fine.
Steps To ReproduceLoad any clip, put it on the timeline, then select render. Select file rendering and mpeg-2 as output. Hit go and watch the progress indicator go nowhere.

Check on the output directory, and see that the output file is created and growing....
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files

- Relationships

-  Notes
evorster (reporter)
2011-05-27 21:58

Progress indication only seems to be stuck at 0% on 2000kb/s mpeg-2 output. Works fine with 4000kb/s
j-b-m (administrator)
2011-05-28 21:42

Which project profile are you using? I cannot reproduce...
evorster (reporter)
2011-05-30 07:49


No matter what I try now, I can't make it do it either.
Please close the bug. If I run into it again, I'll open a new bug, with hopefully some more information.
j-b-m (administrator)
2011-05-30 12:14

Ok then. I am wondering if the bug could be related to the filename of the rendered file or it's location, for example rendering to a removable drive... Anyways, waiting for more input
evorster (reporter)
2011-05-31 03:00


1024x576 16:9 PAL is the profile that has the incorrect progress meter.

I'm rendering to a USB thumbdrive, but exactly the same settings worked normally with another profile.

It has nothing to do with mpeg-2, as it's now doing the same thing with rendering to divx. It was the profile all along.
evorster (reporter)
2011-09-30 20:04

Hmm.. a long time has passed on this one.
I do have some new info. I have been seeing this error on and off, on all the rendering profiles I use.

I presume it's got something to do with the way software gets built on this system. Funny thing is that without any changes to the system it would sometimes work, and sometimes not.

In any case, here is the output from running kdenlive from the command line when this error occurs:

//STARTING RENDERING: true , false , "/usr/bin/melt" , "atsc_1080p_25" , "avformat" , "-" , "/tmp/kde-evert/kdenliveS17930.mlt" , "/data/Videos/Evert_HD/2010/05_13_Namibia_South_Tour_remaster.webm" , () , ("acodec=libvorbis", "ab=192k", "ar=44100", "aq=50", "vcodec=libvpx", "minrate=0", "vb=8000k", "aspect=@16/9", "maxrate=16000k", "g=120", "qmax=42", "qmin=10", "threads=2", "real_time=-1") , -1 , -1
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id: 0x6c1f04b
Object::connect: No such signal QDBusAbstractInterface::abortRenderJob(const QString&)
Started render process: "/usr/bin/melt" "/tmp/kde-evert/kdenliveS17930.mlt -profile atsc_1080p_25 -consumer avformat:/data/Videos/Evert_HD/2010/05_13_Namibia_South_Tour_remaster.webm progress=1 acodec=libvorbis ab=192k ar=44100 aq=50 vcodec=libvpx minrate=0 vb=8000k aspect=@16/9 maxrate=16000k g=120 qmax=42 qmin=10 threads=2 real_time=-1"

j-b-m (administrator)
2011-10-02 07:52

just to make sure... are you talking about the progress indicator that is inside the Kdenlive render widget, or the progress indicator in KDE's system tray notification widget?
evorster (reporter)
2011-10-02 08:13

Not the progress indicator on the the tray. It's the one that pops up in a new window after you hit the render button. Then you can set format and bitrate and so on. Once you are done there, you click on render, and then it pops over to the next tab in that window. There are progress indicators there on the job queue.

If I leave the computer long enough for the render to complete, I can see the load lessen on my CPU, but the progress indicator is still stuck at 0. The resulting video is perfect, but I have to cancel the job out of the render queue before I am able to close Kdenlive.

I'm not completely convinced that this is not related to something I am doing wrong, either. It may just be that I updated udev or dbus without recompiling the software that depends on those two.

- Issue History
Date Modified Username Field Change
2011-05-27 18:18 evorster New Issue
2011-05-27 21:58 evorster Note Added: 0006749
2011-05-28 21:42 j-b-m Note Added: 0006759
2011-05-28 21:42 j-b-m Assigned To => j-b-m
2011-05-28 21:42 j-b-m Status new => feedback
2011-05-30 07:49 evorster Note Added: 0006783
2011-05-30 07:49 evorster Status feedback => assigned
2011-05-30 12:14 j-b-m Note Added: 0006784
2011-05-31 03:00 evorster Note Added: 0006789
2011-09-30 20:04 evorster Note Added: 0007379
2011-10-02 07:52 j-b-m Note Added: 0007389
2011-10-02 08:13 evorster Note Added: 0007390

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker