View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002173KdenliveEffectspublic2011-06-15 22:472011-07-18 22:24
Assigned Toj-b-m 
Platform64 bitOSUbuntu LinuxOS Version8.10
Product Version0.8 
Target VersionFixed in Version 
Summary0002173: 'Alpha shape' effect doesn't render when combined with 'composite' transition
DescriptionI have two clips (actually the same clip split across two video tracks).
On one clip I have the 'Alpha shapes' effect to create a transparent rectangle.
Then I apply the 'composite' transition so that one clip shows through the 'hole' in the other.
This works fine in the preview window, but whatever format I render into, the composite doesn't happen in the rendered video; I just get one video track.

Interestingly, the video track I see is track 2 - it's as if track 1 (which has the effect applied to it) has become totally transparent.
Steps To ReproduceSplit clip between two video tracks; use 'alpha shapes' effect and 'composite' transition. Render.
Additional InformationNote that the composite transition DOES work OK if I remove the 'alpha shapes' effect and set opacity to 50%, then render - you see one clip 'ghosted' through the other, as you would expect.
Therefore I suspect the problem is with the effect and not the composite transition...?

Built using script from kdenlive website
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files? file icon Disint3.kdenlive [^] (12,825 bytes) 2011-06-18 16:17
? file icon [^] (10,370 bytes) 2011-06-19 12:51
txt file icon script001.txt [^] (727 bytes) 2011-06-19 12:51 [Show Content]

- Relationships

-  Notes
j-b-m (administrator)
2011-06-17 21:59

Works for me. Are you trying to render to a different frame size than your project's profile?
thewalrusofhate (reporter)
2011-06-18 12:19

Nope, 1280 x 720 the whole way. Original clip is H.264, transcoded into lossless .mkv file. Tried rendering in H.264, MPEG2, MPEG4, but always same result. Can I capture any outputs from kdenlive or send you the .xml file it saves as?
j-b-m (administrator)
2011-06-18 16:03

Please attach your .kdenlive project file to the bug report
thewalrusofhate (reporter)
2011-06-18 16:18

There you go; lemme know if I can send anything else.
j-b-m (administrator)
2011-06-19 08:29

Can you render using the "Generate script" option and send me the generated files?
The 2 files will be in "~/kdenlive/scripts", called "" and ""
thewalrusofhate (reporter)
2011-06-19 12:52

Done; renamed the .sh script since Mantis didn't like it.
j-b-m (administrator)
2011-06-20 10:32

Did not yet find the problem... could you try playing both files (the .kdenlive project file and the .mlt generated by the script) with mlt's command line player and tell me if effects are displayed?

in a terminal:
melt myfile.mlt
j-b-m (administrator)
2011-06-20 20:09

There is someting strange in the file generated with the "Generate script" option.
You have 2 effects on the upper clip:

* Alpha shape
* Alpha gradient

And the "Alpha shape" effect is disabled...
So did you add the "alphe gradient" effect? And can you make sure that the "alpha shape" effect is not disabled before rendering?
thewalrusofhate (reporter)
2011-06-20 20:45

OK, sorry about the gradient effect - I've been trying different things to try and get it to work. Gradient had a similar effect to 'alpha shapes', but again - I could see it in the preview, but not in the rendered output file.

Having turned 'Alpha shapes' back on, turned off 'Alpha gradient', re-generated the output mp4 and the script file, result:

mp4 file still does not have effect; only video track 2 is visible
when .sh.mlt file played in mlt player, it DOES have the effect, just as it appears in the preview
thewalrusofhate (reporter)
2011-07-05 21:42

Update: using the version of Kdenlive installed through the Ubuntu software centre (0.7.8) the Alpha Shape and composite combination renders correctly.

(sadly this doesn't solve my problem, I need some of the effects from the more recent version)

Is there some way to compare the log files for the two versions, see what they're doing differently?
thewalrusofhate (reporter)
2011-07-18 22:24

I now have a properly working version from the Synaptic repository manager; I managed to achieve the desired effect in the end.
Must have been something I did wrong in installing... thanks for looking into it.

- Issue History
Date Modified Username Field Change
2011-06-15 22:47 thewalrusofhate New Issue
2011-06-17 21:59 j-b-m Note Added: 0006905
2011-06-17 21:59 j-b-m Assigned To => j-b-m
2011-06-17 21:59 j-b-m Status new => feedback
2011-06-18 12:19 thewalrusofhate Note Added: 0006907
2011-06-18 12:19 thewalrusofhate Status feedback => assigned
2011-06-18 16:03 j-b-m Note Added: 0006909
2011-06-18 16:17 thewalrusofhate File Added: Disint3.kdenlive
2011-06-18 16:18 thewalrusofhate Note Added: 0006910
2011-06-19 08:29 j-b-m Note Added: 0006913
2011-06-19 12:51 thewalrusofhate File Added:
2011-06-19 12:51 thewalrusofhate File Added: script001.txt
2011-06-19 12:52 thewalrusofhate Note Added: 0006917
2011-06-20 10:32 j-b-m Note Added: 0006922
2011-06-20 20:09 j-b-m Note Added: 0006923
2011-06-20 20:45 thewalrusofhate Note Added: 0006925
2011-07-05 21:42 thewalrusofhate Note Added: 0007040
2011-07-18 22:24 thewalrusofhate Note Added: 0007087

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker