View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002340KdenliveBuild Systempublic2011-10-01 18:522011-10-25 21:05
Assigned To 
Platform64 bitOSFedoraOS Version15
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002340: cannot build kdenlive with latest kde 4.7.1 and qt 4.8beta
DescriptionI upgraded Fedora 15 with the redhat kde-unstable repository in order to get the latest KDE and digikam. I now cannot build kdenlive using the build script. This included updated qt 4.8.0-beta and kde 4.7.1. I know that these are not official yet, but thought I would report anyway and see if this could be easily fixed.

[ 42%] [ 43%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/addclipcommand.o
Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/main.o
[ 43%] [ 43%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/mainwindow.o
Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/customruler.o
/home/gsking/programs/src/kdenlive_build_scripts/src/kdenlive/src/videoglwidget.cpp: In member function 'virtual void VideoGLWidget::resizeGL(int, int)':
/home/gsking/programs/src/kdenlive_build_scripts/src/kdenlive/src/videoglwidget.cpp:80:35: error: 'gluOrtho2D' was not declared in this scope
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/videoglwidget.o] Error 1
make[2]: *** Waiting for unfinished jobs....
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
gsking1 (reporter)
2011-10-10 03:01

I appear to have solved my problem for now. I added #include "/usr/include/GL/glu.h" to videoglwidget.cpp
It compiles and seems to work. No idea if this is the correct way to fix it or not?
dracoroot7 (reporter)
2011-10-25 14:46
edited on: 2011-10-25 16:01

have the same problem with qt4.8rc under archlinux and you solution worked for me.
Was having some project monitor issues, but not sure if related to qt4.8. I will do more test.

edit: Like I said I'm not sure if this is a qt 4.8 issue, but for my project monitor to show correctly I have to click on a clip in the project tree, then I can click back in the time line and the project monitor shows properly.

j-b-m (administrator)
2011-10-25 21:05


The monitor not properly showing video on startup or sometimes when switching monitor is a separate issue that was just fixed in svn rev. 5989

- Issue History
Date Modified Username Field Change
2011-10-01 18:52 gsking1 New Issue
2011-10-10 03:01 gsking1 Note Added: 0007429
2011-10-25 14:46 dracoroot7 Note Added: 0007460
2011-10-25 16:01 dracoroot7 Note Edited: 0007460 View Revisions
2011-10-25 21:05 j-b-m Note Added: 0007462

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker