View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002617KdenliveRenderingpublic2012-05-20 12:592012-06-05 14:39
Assigned Toj-b-m 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product Version0.9 
Target VersionFixed in Version 
Summary0002617: H.264 rendering fails
DescriptionWhen an H.264 file is rendered, at the end, the following error is generated :

Rendering of /home/fcoiffie/kdenlive/enterrement.mp4 crashed
[NULL @ 0x7efef448f3a0] [Eval @ 0x7efefc0a03a0] Invalid chars '.6' at the end of expression '0.6'
[NULL @ 0x7efef448f3a0] Unable to parse option value "0.6"
Steps To Reproduce1. Select Render Project
2. Destination : File rendering
3. Type : H.264 with default options

Generated parameters are :
f=mp4 hq=1 acodec=aac ab=%audiobitrate+'k' ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=%bitrate+'k' g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar pass=%passes
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon melt-xvid4-crash.txt [^] (59,142 bytes) 2012-06-05 14:35 [Show Content]

- Relationships

-  Notes
j-b-m (administrator)
2012-05-20 18:32

can you tell us which locale you use? In a terminal, type:


and paste the result here
fcoiffie (reporter)
2012-05-20 19:01

My locale :

j-b-m (administrator)
2012-05-20 21:00

I cannot reproduce your problem, which FFmpeg / libx264 versions are you using?
fcoiffie (reporter)
2012-05-20 21:22

Those versions:
j-b-m (administrator)
2012-05-20 21:44

I need you to test something to know if the problem is locale related. Can you try to create a new rendering profile based on H.264, replacing the qcomp "0.6" value with "0,6" (use a comma instead of a dot).

For this, go in the render dialog, select H.264 and create a new profile (Create new profile icon above the profiles list).

Give it a random name (like test) and edit the parameters so that instead of "qcomp=0.6" you have "qcomp=0,6".

Save the profile (by clicking ok) and try to render with this modified profile. Does it work? Do you get another error message?
fcoiffie (reporter)
2012-05-21 09:26

It's strange...
With "qcomp=0,6", rendering crashes also but without any messages.

I forgot to mention that in both cases, as the error occurs at the end of the rendering, the output file exists and seems to work. So, I don't know what has crashed, except the kdenlive message.
fcoiffie (reporter)
2012-05-24 15:00

In fact, there is a segfault at the end of melt execution :

#0 pthread_join (threadid=140737266575104, thread_return=0x0) at pthread_join.c:46
#1 0x00007ffff5ca7dd3 in consumer_stop (consumer=<optimized out>) at consumer_avformat.c:366
0000002 0x0000003d5f01b607 in mlt_consumer_stop (self=0x6e2970) at mlt_consumer.c:1418
0000003 0x00007ffff5ca8599 in consumer_close (consumer=0x6e2970) at consumer_avformat.c:2011
0000004 0x00000000004038b3 in main (argc=<optimized out>, argv=<optimized out>) at melt.c:937
fcoiffie (reporter)
2012-05-24 16:37

Last git version of mlt seems to correct this segfault.
Tested with :

commit b39198884603dd87583b21c840eb595dcaf3708c
Author: Dan Dennedy <>
Date: Sat May 19 21:44:06 2012 -0700

    fix decklink build for OS X
waddlesplash (reporter)
2012-05-25 16:09
edited on: 2012-05-25 16:16

I ran into the same issue, and the outputted video works. This happens to me on both MPEG2 and MPEG4 (not H-264) rendering. I have Kdenlive 0.9, MLT/Melt 0.7.8, Kubuntu 12.04. (Kdenlive/MLT were installed from the PPA repo.) The problem I encountered is that I can't run the video through a Melt command without libx264 choking over it and giving me strange messages. However, running the video through FFmpeg/AcConv works fine (not to MP4).

VLC plays the file correctly, though, which is odd, because it uses libx264....

EDIT: I must've run Melt incorrectly, now it runs fine on the exported clip. It crashes (segfault) on ending, but the file is not corrupt: VLC plays it without a problem. Perhaps there is some problem in Melt that causes it to run libx264 improperly?

j-b-m (administrator)
2012-06-05 13:17

The problem should be fixed in MLT 0.8, please test
eddrog (developer)
2012-06-05 13:26

I have tested yesterday with MLT 0.8, ffmpeg 10.x and kdenlive 0.9.2. It worked fine. Should be solved.
sunab (developer)
2012-06-05 14:39

With MLT 0.8.0 no more crashes with the h.264 profile. But I found a similar problem this the Xvid4 profile only if two pass rendering is enabled. Backtrace attached.

Crash at the end of rendering process, video output seem to be fine.

- Issue History
Date Modified Username Field Change
2012-05-20 12:59 fcoiffie New Issue
2012-05-20 18:32 j-b-m Note Added: 0008061
2012-05-20 18:32 j-b-m Assigned To => j-b-m
2012-05-20 18:32 j-b-m Status new => feedback
2012-05-20 19:01 fcoiffie Note Added: 0008062
2012-05-20 19:01 fcoiffie Status feedback => assigned
2012-05-20 21:00 j-b-m Note Added: 0008064
2012-05-20 21:22 fcoiffie Note Added: 0008065
2012-05-20 21:44 j-b-m Note Added: 0008066
2012-05-21 09:26 fcoiffie Note Added: 0008070
2012-05-24 15:00 fcoiffie Note Added: 0008081
2012-05-24 16:37 fcoiffie Note Added: 0008082
2012-05-25 16:09 waddlesplash Note Added: 0008083
2012-05-25 16:16 waddlesplash Note Edited: 0008083 View Revisions
2012-06-05 13:17 j-b-m Note Added: 0008112
2012-06-05 13:17 j-b-m Status assigned => feedback
2012-06-05 13:26 eddrog Note Added: 0008113
2012-06-05 14:35 sunab File Added: melt-xvid4-crash.txt
2012-06-05 14:39 sunab Note Added: 0008115

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker