View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002782KdenliveRenderingpublic2012-10-14 19:292012-10-22 10:16
Assigned Toj-b-m 
Platform32 bit intel and alikeOSUbuntuOS Version12.04
Product Version0.8.2.1 
Target VersionFixed in Version 
Summary0002782: *.xcf files render into huge INVALID title
Descriptionplaying the kdenlive's rendered *.xcf clip results into huge INVALID title instead the expected title.
Steps To Reproduce1) put some title.xcf file (created by gimp) onto the timeline.
2) Render project into clip.mp4 (probably output format does not matter).

Additional InformationNote: kdenlive's project monitor plays the title correctly.

Workaround: use *.png files instead.

But what if I already created project with many titles with many effects on them?
Replacing *xcf with *png will require resetting all the effects on them, which is nightmare for me.

I found out that following works:
1) add title.png to the project.
2) save project.
3) exit kdenlive
4) edit proj.kdenlive
< <property name="resource">/../../title.xcf</property>
> <property name="resource">/../../title.png</property>
5) start kdenlive.

Is there any better workaround?
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
j-b-m (administrator)
2012-10-14 22:02

Cannot reproduce in latest Kdenlive version (0.9.2). You can update using sunab's kdenlive ppa: [^]
juzerek (reporter)
2012-10-15 20:45

I just upgraded to kdenlive 0.9.2.
Unfortunatelly, the problem persists.

Am I the only one?
Probably not. Please see: [^]

best regards,
j-b-m (administrator)
2012-10-15 23:32

First, make sure that you don't have several versions of MLT installed.
Then can you please give me the following infos:

1) In a terminal, what is the output of :
melt -query producers | grep qimage

2) What happens if in a terminal you do (use any .xcf image you have):
melt image.xcf
juzerek (reporter)
2012-10-16 19:12

I have only one library installed:
$ sudo dpkg --list | egrep -i me*lt
ii libmlt++3 0.8.2-0ubuntu0~sunab~precise1
ii libmlt-data 0.8.2-0ubuntu0~sunab~precise1
ii libmlt5 0.8.2-0ubuntu0~sunab~precise1
ii melt 0.8.2-0ubuntu0~sunab~precise1

$ melt -query producers | grep qimage
  - qimage

$ file 03.xcf
03.xcf: GIMP XCF image data, version 0, 720 x 576, RGB Color

$ melt 03.xcf
Failed to load "03.xcf"
Failed to load "03.xcf"
Usage: melt [options] [producer [name=value]* ]+
  -attach filter[:arg] [name=value]

best regards,
j-b-m (administrator)
2012-10-19 12:03

I still don't understand what is causing this problem. xcf files load correctly on my Ubuntu 12.10 system, but I can reproduce the bug on Ubuntu 12.04. However I am sure it worked before in 12.04. Xcf support is probably added through some KDE libraries but I have not yet found a solution. still working on it...
juzerek (reporter)
2012-10-19 12:17

In the meantime I asked mlt team for opinion.
Maybe this information will be valuable: [^]

in 2009 I was using fedora/KDE, and it worked. Then I switched to ubuntu 10.04 and since that time it did not work for me.

best regards,
j-b-m (administrator)
2012-10-19 15:05

I just sent a patch for review on MLT's mailing list
juzerek (reporter)
2012-10-21 22:09

Thank You for Your focus and impact on this case.

best regards
j-b-m (administrator)
2012-10-22 10:16

Problem should be solved with recent commit to MLT's git repository

- Issue History
Date Modified Username Field Change
2012-10-14 19:29 juzerek New Issue
2012-10-14 22:02 j-b-m Note Added: 0008461
2012-10-14 22:02 j-b-m Assigned To => j-b-m
2012-10-14 22:02 j-b-m Status new => feedback
2012-10-15 20:45 juzerek Note Added: 0008483
2012-10-15 20:45 juzerek Status feedback => assigned
2012-10-15 23:32 j-b-m Note Added: 0008486
2012-10-16 19:12 juzerek Note Added: 0008487
2012-10-19 12:03 j-b-m Note Added: 0008501
2012-10-19 12:17 juzerek Note Added: 0008502
2012-10-19 15:05 j-b-m Note Added: 0008503
2012-10-21 22:09 juzerek Note Added: 0008529
2012-10-22 10:16 j-b-m Note Added: 0008531
2012-10-22 10:16 j-b-m Status assigned => feedback

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker