View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002851KdenliveBuild Systempublic2012-11-29 18:442013-01-28 19:50
Assigned Toj-b-m 
PlatformLinuxOSBacktrack R3 5- Kernel 3.2.6 x86OS VersionUbuntu 10.04
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002851: Application crashes as soon it's started.
DescriptionEverytime I start the application it crashes making it unable to operate the way it should.
Steps To ReproduceN/A
Additional InformationA Log Copy of the crash while using the steps to get a backtrace:

root@bt:~# gdb kdenlive
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<>... [^]
Reading symbols from /usr/bin/kdenlive...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0xb63a01ea in mlt_properties_get_value () from /usr/lib/
(gdb) thread apply all bt

Thread 1 (Thread 0xb3471720 (LWP 2614)):
#0 0xb63a01ea in mlt_properties_get_value () from /usr/lib/
#1 0xb63881dc in Mlt::Properties::get(int) () from /usr/lib/
0000002 0x082c77f0 in ?? ()
0000003 0x082c9036 in ?? ()
0000004 0x0815aa72 in ?? ()
0000005 0x081388d1 in ?? ()
0000006 0xb5c8bbd6 in __libc_start_main () from /lib/tls/i686/cmov/
0000007 0x0808b411 in _start ()

Additional Information:

I had installed a previous version of Kdenlive (0.7.7) from Synaptic Package Manager, I didn't had running the latest PPA of kdenlive so it was presenting me a very old version. I then ran into the kdenlive website and did all the instructions to update the PPA sources, and finally got the latest version to show up in Synaptic, While it seems that I removed the previous version of kdenlive, through: "aptitude remove kdenlive" command and from Synaptic itself, then tried installing the newest version of Kdenlive, it worked and installed fine... but then when I opened it up it started crashing immediately after each launch of the program.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
AxDSan (reporter)
2012-11-29 19:27

Please Mark it as Solved - Issue was fixed, Apparently it didn't had installed kdenlive-dbg symbols. Thats the only thing it was missing... I installed the symbols. ran again the gdb kdenlive command and then it ran PERFECT! no crashes at all! Amazing what something so tiny can do so much chaos.

- Issue History
Date Modified Username Field Change
2012-11-29 18:44 AxDSan New Issue
2012-11-29 19:27 AxDSan Note Added: 0008678
2012-11-29 21:53 j-b-m Status new => resolved
2012-11-29 21:53 j-b-m Fixed in Version => Recent git
2012-11-29 21:53 j-b-m Resolution open => fixed
2012-11-29 21:53 j-b-m Assigned To => j-b-m
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker