View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002889KdenliveBuild Systempublic2012-12-23 23:342013-01-02 01:30
Assigned Toj-b-m 
PlatformAMD 64 bitOSOpenSUSEOS Version12.1
Product Version0.9.2 
Target VersionFixed in Version 
Summary0002889: Crash on startup
DescriptionBuilt from source, crashes on start up.
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files? file icon kdenlive-20121223-170207.kcrash [^] (2,754 bytes) 2012-12-23 23:34 [Show Content]

- Relationships

-  Notes
j-b-m (administrator)
2012-12-23 23:41

Looks like there is a problem in your MLT installation. How did you install MLT and which version?

You can check if your MLT install is working by trying this in a terminal:

melt color:red

(it should show a red screen)

melt myclip.mpg

Should play your clip

Confoosed (reporter)
2012-12-24 00:22

melt color:red does nothing, just shows the list of options.
Same for "melt myclip.mpg".
I have melt 0.8.6-5.1-x86_64 from the packman repo. The only thing I built by hand was Kdenlive, all other packages were installed from Yast, from a previous Kdenlive install. I had tried to update something (I forget now what it was) and I borked the previous Kdenlive install. Yast (packman repo) does not have the previous version anymore, so I was forced to try installing the new version. Unfortunately, there is at least one missing dependency in packman, so it won't even install that way (I emailed "packman" about that, still waiting for a reply).
Confoosed (reporter)
2012-12-24 00:28

I just tried this to see what would happen:

melt -query "video_codec"

The result:

# You can query the metadata for a specific service using:
# -query <type>=<identifer>
# where <type> is one of: consumer, filter, producer, or transition.

When trying to start Kdenlive, it asks for the path to the profiles.
Mine are in /usr/share/mlt-5/profiles/. Is that a problem? No idea
if that is related to this problem.
j-b-m (administrator)
2013-01-01 19:22

Well first you must ensure that you don't have several versions of MLT installed, that might cause problems. Check you MLT libraries folder:

ls -la /usr/lib/libmlt*

And make sure that you don't have several versions installed (you should only have 0.8.6).

I am surprised about the non standard profiles folder. Maybe you can create a link like this:

sudo ln -s /usr/share/mlt-5 /usr/share/mlt

To have a standard path and try restarting Kdenlive
Confoosed (reporter)
2013-01-01 21:05

I have since built Kdenlive using the build script. That is working great so far, so I'm afraid to mess anything else up. Hopefully the repo for openSUSE (packman) will be fixed in future versions. For now, I am very happy with the build script installation. Thank you for your help, and especially for the build script (or thank the person that wrote it if it wasn't you).
Confoosed (reporter)
2013-01-02 01:29

Just in case you still want the info:

ls /usr/lib64/libmlt*
/usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/

There's nothing in /usr/lib/ though.
Confoosed (reporter)
2013-01-02 01:30

And this:

ls -la /usr/lib64/libmlt*
lrwxrwxrwx 1 root root 15 Dec 23 19:45 /usr/lib64/ ->
lrwxrwxrwx 1 root root 17 Dec 23 19:45 /usr/lib64/ ->
-rw-r--r-- 1 root root 172656 Dec 5 07:59 /usr/lib64/
-rw-r--r-- 1 root root 127912 Dec 5 07:59 /usr/lib64/
lrwxrwxrwx 1 root root 17 Dec 23 19:45 /usr/lib64/ ->
lrwxrwxrwx 1 root root 15 Dec 23 19:44 /usr/lib64/ ->

- Issue History
Date Modified Username Field Change
2012-12-23 23:34 Confoosed New Issue
2012-12-23 23:34 Confoosed File Added: kdenlive-20121223-170207.kcrash
2012-12-23 23:41 j-b-m Note Added: 0008859
2012-12-23 23:41 j-b-m Assigned To => j-b-m
2012-12-23 23:41 j-b-m Status new => feedback
2012-12-24 00:22 Confoosed Note Added: 0008861
2012-12-24 00:22 Confoosed Status feedback => assigned
2012-12-24 00:28 Confoosed Note Added: 0008862
2013-01-01 19:22 j-b-m Note Added: 0008995
2013-01-01 21:05 Confoosed Note Added: 0008996
2013-01-02 01:29 Confoosed Note Added: 0008997
2013-01-02 01:30 Confoosed Note Added: 0008998

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker