View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002943KdenliveRenderingpublic2013-01-15 15:162014-08-06 00:05
Assigned Tovpinon 
StatusresolvedResolutionnot fixable 
Platform32 bit intel and alikeOSUbuntuOS Version12.10
Product Version0.9.2 
Target VersionFixed in Version 
Summary0002943: Unsupported audio codec: pcm_s16le
DescriptionWhen trying to render as a AVI DV all the sub-options are grayed out and I get the message 'Unsupported audio codec: pcm_s16le'.

If I manually edit the .kde/share/config/kdenliverc file and at the end in the section called [unmanaged], add pcm_s16le to the audiocodecs line, then all the AVI DV options come back and the file will render and play (though audio is patchy in VLC player for some reason but ok in other players). I have installed libavcodec-extra-53 and run the configuration wizard (which overwrites my manually added audio codec). As fas as I know, MLT version is current. I'm a recent convert to Linux, so am just getting to grips with things so go easy with any suggestions! I have seen this error reported elsewhere on this forum and have tried all the solutions to no avail.
Steps To ReproduceAlways works, just try to render as AVI DV
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
Dean (reporter)
2013-01-16 21:03

Just checked, Melt is 0.8.2
ttguy (updater)
2013-01-24 12:10

I also have this issue on
kdenlive 0.9.3+git20130117.91ea0353-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130109.ba392dac-0ubuntu0~sunab~precise1
frei0r 1.3.0+git20130119.c3fdd674-0ubuntu0~sunab~precise1
ffmpeg 0.8.4-4:0.8.4-0ubuntu0.12.04.1

I actually have two versions of ffmpeg installed and I point kdenlive at the 0.8.4 from avconv via the kdenlive settings.

I know this issue is related to ffmpeg versions. I wonder if there is some part of kdenlive that does not respect the kdenlive settings for ffmpeg location and it is executing my other version.
Dean (reporter)
2013-01-24 12:45

I'm on ffmpeg 0.8.4 as well

ffmpeg 0.8.4-6:0.8.4-0ubuntu0.12.10.1
libavutil 51. 22. 1 / 51. 22. 1
libavcodec 53. 35. 0 / 53. 35. 0
libavformat 53. 21. 0 / 53. 21. 0
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 15. 0 / 2. 15. 0
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 52. 0. 0 / 52. 0. 0

I'm not sure what all of that means but it might be useful to someone!
peter_b (reporter)
2013-02-04 16:01
edited on: 2013-02-04 16:03

Same problem here.
There are some bug reports (0002766, 0002783, 0002537) which would suggest that it's already fixed, but the problem is still existing in v0.9.4 (from ubuntu-PPA).

User "eddrog" (developer) has posted to look at issue #0002688, but I got a "access denied" when I tried to access that issue.

Is there anything we could help with pinpointing the reason for this issue, as it seems to be quite persistent?

eddrog (developer)
2013-02-05 10:16

@j-b-m: Could you take a closer look. I'm sick for a while. Thanks
Dean (reporter)
2013-02-05 17:27

I did some upgrades, now on:
kdenlive 0.9.4
Melt 0.8.8
ffmpeg 0.8.5-6:0.8.5-0ubuntu0.12.10.1
libavutil 51. 22. 1 / 51. 22. 1
libavcodec 53. 35. 0 / 53. 35. 0
libavformat 53. 21. 1 / 53. 21. 1
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 15. 0 / 2. 15. 0
libswscale 2. 1. 0 / 2. 1. 0

The problem is the same as before, Unsupported audio codec: pcm_s16le appears when rendering.
peter_b (reporter)
2013-02-12 11:04
edited on: 2013-02-12 11:05

I've tried a workaround, by selecting a different profile (which doesn't use pcm_s16le, but e.g. FLAC) and then used the "create script" functionality in Kdenlive's render dialogue to create a shell-script with the MELT call inside.

Inside the script, I've changed the audio codec parameter to "acodec=pcm_s16le".

Creating the exported video worked, but the created AVI files with FFv1/pcm_s16le were broken:
1) The duration was displayed incorrectly by some players (e.g. VLC)
2) The created file did not playback in e.g. VirtualDub

When I've removed "acodec=pcm_s16le" and replaced it with "an=1", duration and playback was behaving correclty - but of course, had no audio.
(Was just for triaging the problem)

Senbee (reporter)
2013-02-13 16:33

1- Open ~/.kde/share/config/kdenliverc
2- Go to [unmanaged] session
3- At the end of "audiocodecs=" line, add ",pcm_s16le" (without quotes)
4- Save it.

I had to add also ",libmp3lame" and ",pcm_s16be". Also, ",libx264" and ",libxvid" at the end of "videocodecs=" line to make it work properly.
eddrog (developer)
2013-02-13 16:42

Did you try in settings(misc): Bypass codec verification ?

There are some buggy ffmpeg/avconf versions. So the verifaction fails for some codecs.
Dean (reporter)
2013-02-14 10:23

Thanks for the suggestions.

OK, so I tried 'Bypass codec verification' and the render in AVI DV option appears!
So I render the file as an AVI Pal and the video will render.
Now this will play video in VLC Player, Xine and Movie Player, but the audio will only play in Movie Player. In VLC and Xine all I get is pulsing noise. Even in movie player there seems to be quite a lot of background hiss.
This is largely the same effect as I get when I manually add the pcm_s16e to the audiocodecs= line in ~/.kde/share/config/kdenliverc
peter_b (reporter)
2013-02-14 16:02

I did try with "Bypass codec verification" checked and exported MKV (FFv1/pcm_s16le) and the audio is fine and plays back in VLC.

I've also verified that the audio is correctly exported by opening both: the MKV audio track and a phase-inverted original WAV in Audacity.

Mixing them together returns perfect silence over the whole period of the video, which means that kdenlive's pcm_s16le exported audiotrack matches the original.
Dean (reporter)
2013-02-14 18:32

Thanks peter_b, can I check what you mean by 'checked and exported MKV (FFv1/pcm_s16le)'?

I'm just starting with Linux so getting used to being a little more 'hands on' than just expecting everything to work out of the box!
peter_b (reporter)
2013-02-14 21:15

I enabled the option "bypass codec verification" in the "kdenlive settings > misc", restarted kdenlive and then exported my project as Matroska (MKV) container with FFv1 as video codec and pcm_s16le as audio codec.

I was able to reproduce Dean's "pulsing audio" problem, by exporting to AVI rather than MKV:

VLC plays a fraction of a second of sound, then mutes, then plays, then mutes, ... and so on.

Trying to play the created AVI file with "ffplay" (current git HEAD) returns a flood of repeating error messages like this (while the sound is stuttering):

ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred 0B f=0/0

Remuxing the AVI using ffmpeg produces a correct file:
"$ ffmpeg -i test.avi -acodec copy -vcodec copy test2.avi"
Dean (reporter)
2013-02-16 15:57

I don't seem to have Matroska as an included container in the profiles. Is it included by default or do I have to edit an existing profile to create it?
peter_b (reporter)
2013-02-16 21:54

In my setup it came with the default profiles.
In "Render > Render Project" Select "Lossless / HQ" as Destination. It's the "FFv1 lossless (video) + PCM (sound)" profile I've used.

However, you might want to (a) try to export as "Raw DV" (if MLT is having problems creating AVIs), or you choose "File Rendering > AVI DV > DV PAL 4:3" and then modify the container to be "matroska".

Might look like this:
"f=matroska vcodec=dvvideo pix_fmt=yuv420p acodec=pcm_s16le s=720x576 mlt_profile=dv_pal"

File suffix is "mkv".
Dean (reporter)
2013-02-21 13:37

OK, I wondered if it was me messing around with my installation causing trouble, so I did a total clean install of Ubuntu 12.10 on a different laptop (Lenovo x61). I did the OS install, then updated, then installed kdenlive from the terminal via sudo add-apt-repository ppa:sunab/kdenlive-release && sudo apt-get update && sudo apt-get install kdenlive
After this I'm on Melt 0.8.8 ffmpeg 0.8.5-6:0.8.5-0ubuntu0.12.10.1

I still get 'Unsupported audio codec: pcm_s16le' from the render option.

If I enable 'bypass codec verification' then when I run the configuration wizard I get the error "The following codecs were not found on your system. Check our online manual if you need them: pcm_s16le"

However, I can still render .avi but the audio is still broken in VLC player.

Thanks peter_b for your help!
goldphnx (reporter)
2014-03-09 03:18

I also have this problem with 0.9.7 and melt 0.9.1 Ubuntu 13.10 xfce 4.12

I am more interested in a cause or resolution rather than a workaround that either triples my time and effort or doesn't last after an update or reboot.

I've tried editing config files and other attempts mentioned above, but this bug has been around for over a year and I've had to reluctantly move away from Kdenlive because of it.

Does anyone have any new information?
eddrog (developer)
2014-03-11 18:48

The problem is that in ubuntu (debian) libav is used as multimedia lib instead of ffmpeg and it is absolutely buggy and sucks. I wrote already to the debian team to switch to ffmpeg again but I don't know if and when it will be done.

So try to use the version from the build server: [^]

1) Download
2) unpack
3) cd kdenline
4) ./start-kdenlive -n
vpinon (administrator)
2014-08-06 00:05

Confirm this is a libav problem, use builds with ffmpeg or wait debian (&derivatives) to bring ffmpeg back

- Issue History
Date Modified Username Field Change
2013-01-15 15:16 Dean New Issue
2013-01-16 21:03 Dean Note Added: 0009098
2013-01-24 12:10 ttguy Note Added: 0009116
2013-01-24 12:45 Dean Note Added: 0009119
2013-02-04 16:01 peter_b Note Added: 0009173
2013-02-04 16:01 peter_b Note Edited: 0009173 View Revisions
2013-02-04 16:03 peter_b Note Edited: 0009173 View Revisions
2013-02-05 10:15 eddrog Assigned To => j-b-m
2013-02-05 10:15 eddrog Status new => assigned
2013-02-05 10:16 eddrog Note Added: 0009176
2013-02-05 17:27 Dean Note Added: 0009186
2013-02-12 11:04 peter_b Note Added: 0009256
2013-02-12 11:05 peter_b Note Edited: 0009256 View Revisions
2013-02-13 16:33 Senbee Note Added: 0009261
2013-02-13 16:42 eddrog Note Added: 0009262
2013-02-14 10:23 Dean Note Added: 0009268
2013-02-14 16:02 peter_b Note Added: 0009271
2013-02-14 18:32 Dean Note Added: 0009272
2013-02-14 21:15 peter_b Note Added: 0009273
2013-02-16 15:57 Dean Note Added: 0009275
2013-02-16 21:54 peter_b Note Added: 0009276
2013-02-21 13:37 Dean Note Added: 0009310
2014-03-09 03:18 goldphnx Note Added: 0009753
2014-03-11 18:48 eddrog Note Added: 0009757
2014-08-06 00:05 vpinon Note Added: 0010195
2014-08-06 00:05 vpinon Status assigned => resolved
2014-08-06 00:05 vpinon Resolution open => not fixable
2014-08-06 00:05 vpinon Assigned To j-b-m => vpinon

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker