View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003186KdenliveEffectspublic2013-11-01 21:192014-03-02 21:50
Assigned Tovpinon 
Platform64-bitOSArchLinuxOS VersionCurrent
Product Version0.9.6 
Target VersionFixed in VersionRecent git 
Summary0003186: Crash when disabling effect
DescriptionAny effect applied to the video can be seen on the preview window but when clicking on the little eye to disable the effect then Kdenlive crashes
Steps To Reproduce- Create a blank project
- Import a clip with proxy
- Add clip to timeline
- Apply any effect like Color/Saturation
- Change the effect parameter (i.e. crank up the saturation)
- Preview should show the modified clip and playback should work
- Disable the effect by clicking on the little "eye" in the effect window
- Kdenlive should crash!
Additional InformationI have this bug on a brand new ArchLinux installation. The weird thing is that I'm running the exact same setup on both machines (same package versions) and have the bug on only the new one.
TagsNo tags attached.
Build/Install Method(select)
Attached Filestxt file icon crash-effects.txt [^] (18,294 bytes) 2013-11-01 21:19 [Show Content]
txt file icon kdenlive-bt.txt [^] (38,012 bytes) 2013-11-03 11:48 [Show Content]

- Relationships

-  Notes
alphazo (reporter)
2013-11-02 21:44

Forgot to mention the version of MLT I'm using 0.9.0-5. Exactly the same found on my former laptop that doesn't show the problem.
alphazo (reporter)
2013-11-02 22:10

My new system is based upon Intel i7 4770S (Haswell).
Could that be related to the following article on lock elision on this core here: [^]

FYI, I'm running a pre-compiled version of glibc 2.18-9
alphazo (reporter)
2013-11-02 23:02

One more thing. I checked the compile options for my pre-compiled glibc 2.18-9 [^]

And it clearly states --enable-lock-elision. I then tried to recompile it without this option but the compilation failed for another reason.
alphazo (reporter)
2013-11-03 11:10

Ok guys, I went ahead and recompiled glibc 2.18-9 without the default--enable-lock-elision and the problem is gone.

Now I don't know if the problem is with Kdenlive code or glibc impelementation of the lock elision feature found on recent Haswell CPU.
alphazo (reporter)
2013-11-03 11:47

See a more detailed backtrace using the pre-compiled glibc with --enable-lock-elision.
alphazo (reporter)
2014-01-14 22:03

I tried a bunch of KDE applications and none of them crash when using glibc with --enable-lock-elision. Only Kdenlive crashes if I use the default glibc with that option turned on. Recompiling it without it makes the probelm to go away on my Haswell CPU (lock elision is very specific to that particular CPU).
vpinon (administrator)
2014-02-14 12:04

I may have found the problem, can you try recompiling git as of now?
alphazo (reporter)
2014-02-21 21:31

I recompiled 0.9.6 with the patch proposed at [^] and it fixed my issue with recent glibc that have --enable-lock-elision enabled by default. Bug can be closed now. I told you guys it was not glibc the issue ;) Thanks for finding this anyway.
vpinon (administrator)
2014-03-02 21:50

thanks for your feedback!
(never said kdenlive was not the culprit ;) )

- Issue History
Date Modified Username Field Change
2013-11-01 21:19 alphazo New Issue
2013-11-01 21:19 alphazo File Added: crash-effects.txt
2013-11-02 21:44 alphazo Note Added: 0009627
2013-11-02 22:10 alphazo Note Added: 0009628
2013-11-02 23:02 alphazo Note Added: 0009629
2013-11-03 11:10 alphazo Note Added: 0009630
2013-11-03 11:47 alphazo Note Added: 0009631
2013-11-03 11:48 alphazo File Added: kdenlive-bt.txt
2014-01-14 22:03 alphazo Note Added: 0009660
2014-02-14 12:04 vpinon Note Added: 0009697
2014-02-14 12:04 vpinon Assigned To => vpinon
2014-02-14 12:04 vpinon Status new => feedback
2014-02-21 21:31 alphazo Note Added: 0009737
2014-02-21 21:31 alphazo Status feedback => assigned
2014-03-02 21:50 vpinon Note Added: 0009746
2014-03-02 21:50 vpinon Status assigned => resolved
2014-03-02 21:50 vpinon Fixed in Version => Recent git
2014-03-02 21:50 vpinon Resolution open => fixed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker