View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003221KdenliveRenderingpublic2014-02-15 05:132014-03-19 20:32
Assigned Tovpinon 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionno change required 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product Version0.9.6 
Target VersionFixed in Version 
Summary0003221: Ridiculously High bitrate H.264 mp4 file is generated
DescriptionPreviously I used the modified default h.264 profile(added crf=0 and preset=slow), and generates files with bitrate around 2500kbits/s. However, today when I edited a similar video (it is a gameplay, in series with the previous one, so the bitrate should be similar), but it generates ridiculously large file like 8GB, with bitrate > 50000kbits/s. I have to use ffmpeg manually to lower the bitrate with -b:v and -maxrate, but the quality of the video does not change so much. I am now trying to find if I did something to the system since there was a major world update after my previous, "normal", video. However, it may also be a bug of kdenlive
Steps To ReproduceThe profile parameter is: f=mp4 hq=1 acodec=aac ab=%audiobitrate+'k' ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=%bitrate+'k' g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar pass=%passes crf=0 preset=slow

I just used the recording video and edited as normal. It also appears on a camera recording, so the original clip may not be the problem.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon kdenliverc.txt [^] (9,023 bytes) 2014-02-21 22:46 [Show Content]
xml file icon profiles.xml [^] (6,291 bytes) 2014-03-02 21:54

- Relationships

-  Notes
vpinon (administrator)
2014-02-17 16:21

Transcoding is actually done through MLT, which itself calls ffmpeg/libav, itself calling libx264 for h264.
So this should come from a libx264 update (or ffmpeg/libav interpreting arguments differently).
Long time back I also was not very sure with crf=0, I got used to crf=2 to 5 for good quality exports...

Any progress on your side?
carldong (reporter)
2014-02-17 16:24

Tried CRF=6, slightly smaller but still huge. Before this issue I did a huge world update, and added split-debug and reemerged glibc. Now I reversed the glibc and I'm trying again. If I transcode a video using ffmpeg directly with ffmpeg -i Original.mkv -crf 0 Transcoded.mkv, I have no problem.
vpinon (administrator)
2014-02-17 21:49

then there is a problem in passing the arguments between kdenlive/mlt/libavcodec.
yet your setting looks a bit too verbose:
the x264 presets ("settings=slow") made obsolete several options that are still in old kdenlive presets (like coder/trellis/flags2); similarly the x264 "crf" quality overrides the q* settings, and in this VBR case setting a bitrate becomes a bit strange! maybe a big clean relying on defaults (the time when they where wrong is long back) would not give worse results?! personnaly I don't set anything else than the codecs and quality...
carldong (reporter)
2014-02-17 21:54

Well, I am not sure how arguments are passed. The crf argument is used to get lossless since it seems that the default argument does not give lossless render. The problem is, even the default H.264 profile gives huge file, and before a particular time, everything including my modified version was fine.
carldong (reporter)
2014-02-21 22:46

Removed ~/kdenlive and kdenliverc, and seems to work again... Needs more testing.
vpinon (administrator)
2014-03-02 22:17

On 02-19 (git 8f16f0db) I cleaned the encoding profiles to simply use MLT presets.
You can try saving the attached profiles.xml in either ~/.kde/share/apps/kdenlive/export/ (user config) or /usr/share/kde4/apps/kdenlive/export/ (system config => sudo)
There are lossless settings that I (very) quickly checked.
Working for you?
carldong (reporter)
2014-03-02 22:20

Well, currently after I deleted settings it worked fine... Not tested with the attached profiles.xml yet.

- Issue History
Date Modified Username Field Change
2014-02-15 05:13 carldong New Issue
2014-02-17 16:21 vpinon Note Added: 0009713
2014-02-17 16:21 vpinon Assigned To => vpinon
2014-02-17 16:21 vpinon Status new => feedback
2014-02-17 16:24 carldong Note Added: 0009714
2014-02-17 16:24 carldong Status feedback => assigned
2014-02-17 21:49 vpinon Note Added: 0009719
2014-02-17 21:54 carldong Note Added: 0009720
2014-02-21 22:46 carldong Note Added: 0009738
2014-02-21 22:46 carldong File Added: kdenliverc.txt
2014-03-02 21:54 vpinon File Added: profiles.xml
2014-03-02 22:17 vpinon Note Added: 0009747
2014-03-02 22:17 vpinon Status assigned => feedback
2014-03-02 22:20 carldong Note Added: 0009748
2014-03-02 22:20 carldong Status feedback => assigned
2014-03-19 20:32 vpinon Status assigned => resolved
2014-03-19 20:32 vpinon Resolution open => no change required

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker