View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003234KdenliveRenderingpublic2014-03-21 14:082014-08-06 00:02
Assigned ToSesse 
Platform64 bitOSUbuntuOS Version12.10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0003234: Render crashes
DescriptionRender crashes. A few times I've had it not crash, but the output file was garbage: playable garbage with a valid file structure, but the video was just noise.

Also having problems with video in preview being intermittently upside-down and/or garbled colours.

"Successful" render (it didn't crash) - [^]

Input video file and project file - [^]
Steps To ReproduceLoad the project file & input file (link, above) and try to render.
Additional Informationkdenlive - 0.9.7+git20140315.e17bf72d-0ubuntu0~sunab~quantal1
melt - 0.9.1+git20140318.234d3e7f-0ubuntu0~sunab~quantal1
Ubuntu 12.10
Linux cz5000 3.5.0-47-generic 0000071-Ubuntu SMP Wed Feb 19 00:00:07 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

error log (from a crashed render attempt) attached.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Filesgz file icon error-log.txt.gz [^] (629 bytes) 2014-03-21 14:08

- Relationships

-  Notes
vpinon (administrator)
2014-03-24 23:35

We recently activated OpenGL filters (movit), and you are triggering the first bugs after this important switch, thanks for the report!
For stable use you may rather use the "release" PPA rather than "svn", but don't hesitate to keep testing regularly...
vpinon (administrator)
2014-03-24 23:44

@Sesse: keeping you informed if you find time to help on this (fix or advice)?
atom (reporter)
2014-03-25 00:20

Happy to report bugs in the latest git, but after this one I had to switch to 0.9.6-0ubuntu0~sunab~quantal1 to get some work done. Is there a way to have both versions installed in Ubuntu?
Sesse (developer)
2014-03-25 00:32

Kdenlive doesn't render by itself, but calls out to the melt binary, and it looks like melt is trying to use Movit effects, but for some reason that fails. Are you sure your melt is actually compiled against the same MLT as Kdenlive is? Can you try giving -consumer xgl to the melt rendering command line?
atom (reporter)
2014-03-25 00:46

When it crashed, melt was 0.9.1+git20140318.234d3e7f-0ubuntu0~sunab~quantal1

Since changed to 0.8.8-0ubuntu0~sunab~quantal1

There were also problems in the preview window - Videos upside or messed up colours, but only when selecting videos in the time-line. I didn't have any problems previewing videos from the "project tree".
vpinon (administrator)
2014-03-25 00:47

Having 2 conflicting versions is not so easy.
If you do not want to rebuild every update, maybe installing the packages to test in a chroot would be the solution (see debootstrap, [^] for example).
However I have never tested and don't know how it behaves with the multimedia stack...
Don't hesitate to share your experience ;-)
Sesse (developer)
2014-03-28 16:45

What's the status of this? Does it still crash when melt and libmlt come from the same version? Did you try adding -consumer xgl to the melt command line?
Sesse (developer)
2014-04-01 22:52

I've checked a bit around, and it seems rendering is currently broken whenever you have a Movit filter in the loop.

I'm working with the MLT people to fix it, but it seems like this requires Kdenlive to change how it interfaces with melt; it needs to use the qglsl consumer, which can happen in a few different ways, but all of them require a bit of changes in either melt or Kdenlive.

I'm upgrading the severity of this request since Kdenlive obviously should be able to render; we shouldn't have a new release without it.
Sesse (developer)
2014-04-03 01:57

Dan Dennedy has made some changes to melt that will make this easier. For reference, this is the right way to render things with Movit in them:

melt foo.mlt -profile hdv_720_60p -consumer qglsl 0=avformat progress=1 0.ab=192k 0.vb=4000k 0.aspect=@16/9 0.threads=1 0.real_time=-1

So basically, everything except progress= should have a 0. in front, and the consumer changes into "qglsl 0=avformat".

This should hopefully be relatively easy to fix, once I figure out the right relationship between Kdenlive, the renderer process and melt.
j-b-m (administrator)
2014-04-03 08:41

Rendering works for me... Last week I made a change in Kdenlive to insert a glsl.=1 property on the consumer which should automatically trigger the qlsl consumer..

I will test with your project files tomorrow.
Sesse (developer)
2014-04-03 10:31

Well, there was at least one segfault fix in melt since last week, so it's a bit odd that it'd work :-) But maybe those plus the other fixes made it render properly again?

I just tried it here; the .sh script just says that "Rendering of <file> was aborted, resulting video will probably be corrupted.". If I run the command line it prints out manually (and set LANG=C to avoid some . vs , printf issues), it seems to work (can't check the output), but it leaks a 1280*720 texture every frame, so that's rapidly going out of memory.
j-b-m (administrator)
2014-04-03 22:53

I worked on a 10 minutes short movie, using movit white balance effect and a few transitions and rendered it with Kdenlive (using my glsl.=1 trick) and I have 150 witnesses who can testify that the movie was not corrupted :-)

Rendering your project works for me from Kdenlive and using the render script.

However, I am using MLT and Movit from git. I think there is a problem with the sunab packages... I will investigate. Also, the Ubuntu daily builds of Kdenlive provided by Dan Dennedy use his own version of Movit (at least when I checked a few days ago), and rely on an old libGL version which causes crashes on recent Ubuntu versions.

I think many crashes are currently related to problems in packages. I will investigate the problem soon.
Sesse (developer)
2014-04-04 01:03

I've asked Dan if glsl.=1 is a suitable workaround or if it just works by accident. :-)

Dan has his own Movit branch right now because of issues with newer Movit code and some Qt5/OS X/NVidia interactions, as I understand it. When he figures out exactly what's going on, he'll be fast-forwarding.

- Issue History
Date Modified Username Field Change
2014-03-21 14:08 atom New Issue
2014-03-21 14:08 atom File Added: error-log.txt.gz
2014-03-24 23:35 vpinon Note Added: 0009791
2014-03-24 23:44 vpinon Assigned To => Sesse
2014-03-24 23:44 vpinon Status new => assigned
2014-03-24 23:44 vpinon Note Added: 0009793
2014-03-25 00:20 atom Note Added: 0009798
2014-03-25 00:32 Sesse Note Added: 0009799
2014-03-25 00:46 atom Note Added: 0009800
2014-03-25 00:47 vpinon Note Added: 0009801
2014-03-28 16:45 Sesse Note Added: 0009812
2014-04-01 22:52 Sesse Note Added: 0009885
2014-04-01 22:52 Sesse Severity major => block
2014-04-03 01:57 Sesse Note Added: 0009898
2014-04-03 08:41 j-b-m Note Added: 0009901
2014-04-03 10:31 Sesse Note Added: 0009904
2014-04-03 22:53 j-b-m Note Added: 0009912
2014-04-04 01:03 Sesse Note Added: 0009918
2014-08-06 00:02 vpinon Status assigned => resolved
2014-08-06 00:02 vpinon Resolution open => suspended

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker