View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003237KdenliveMLTpublic2014-03-29 00:592014-08-06 00:30
Assigned Tovpinon 
Platform64 bitOSGentoo LinuxOS Version
Product VersionRecent git 
Target VersionFixed in Version0.9.8 
Summary0003237: Make filters on GPU (Movit based) optional
DescriptionIt's very sad that kdenlive becomes second lightworks in sense of system requirements. I do not have powerful video card, do not want to use proprietary driver but I want kdenlive. Please allow! May be add some configure flag, like for frei0r's filters, or something else.
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Fileslog file icon make-check.log [^] (38,618 bytes) 2014-04-01 23:25 [Show Content]
txt file icon varchar-glxinfo.txt [^] (58,498 bytes) 2014-04-01 23:33 [Show Content]

- Relationships

-  Notes
maverickp (reporter)
2014-03-29 22:39

Me too.
Sesse (developer)
2014-03-30 03:03


What kind of video card is it that you have that doesn't support Movit? (Have you actually tried?) OpenGL 2.1 came out eight years ago.

Note that there is only so long you can expect to run a graphical Linux system at all without a GPU; more and more systems require compositing, and at some point, supporting a decade old machines just isn't worth it anymore.
varchar (reporter)
2014-03-30 23:16

Hello. I use kdenlive on old (2000y) but good for my simple needs ?ompaq armada e500 laptop with ATI mach64 video card. Today - half a day, for example. That's may be a laugh end I'm a retrograde... But I want be able to update to less buggy and glucky latest kdenlive versions.
Sesse (developer)
2014-03-30 23:26

OK, if you think it is important for Kdenlive to support fifteen year old laptops (at the expense of working on one of the other 800 open bugs in the bug tracker), then either write a patch, or convince someone else to do so. In the end, I guess it's j-b-m's call what goes in or out.
varchar (reporter)
2014-03-30 23:41

OK, if you think it is important for kdenlive to filter on GPU (at the expense of working on one of the other 800 open bugs in the bug tracker)........
Sesse (developer)
2014-03-30 23:42
edited on: 2014-03-30 23:43

...then I should write a patch? Yes, I did that. And I certainly do.

varchar (reporter)
2014-03-31 13:19

You are the man! Ok, forget.

BTW, can't compile Movit 1.0.3 from your home pahe. After """ ./configure && make """ got the following error:

""" g++ -MMD -MP -Wall -g -O2 -I/usr/src/gtest/include -I/usr/include/eigen3 -I/usr/include/GL -o effect_chain_test.o -c effect_chain_test.cpp
effect_chain_test.cpp:11:25: fatal error: gtest/gtest.h: No such file or directory
compilation terminated.
make: *** [effect_chain_test.o] Error 1 """

Can you help me with it?
Sesse (developer)
2014-03-31 13:50

As the README says, you need to install Google Test (libtest). Your distribution should probably have a package; if not, you can get it from [^]

You also need Eigen ( [^]) and GLEW ( [^]). For Movit 1.1 (ie., what's in git), GLEW has been replaced by libepoxy.
varchar (reporter)
2014-03-31 14:48

Thank you.

With package management system (portage) I installed:

and run into another problems. 1-st:

""" g++ -MMD -MP -Wall -g -O2 -I/usr/src/gtest/include -I/usr/include/eigen3 -I/usr/include/GL -o effect_chain_test.o -c effect_chain_test.cpp
make: *** No rule to make target `/usr/src/gtest/src/', needed by `gtest-all.o'. Stop. """

which I solved by placing gtest src to /usr/src/gtest/
( may be it must be done by package manager and I should report a bug about it? )


""" /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'glDeleteTextures' is defined in DSO /usr/lib64/ so try adding it to the linker command line
/usr/lib64/ could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [effect_chain_test] Error 1 """

Should I build mesa with debug symbols?
Sesse (developer)
2014-03-31 14:51

There's no defined directory for Google Test, unfortunately; you can give make GTEST_DIR=/path/to/gtest if you don't want to put it in /usr/src.

The second sounds more like an issue with your GLEW installation, but you'd need to tell me the command line that caused it. And probably also what /usr/lib/ points to. Debug symbols are not relevant here.
varchar (reporter)
2014-03-31 15:14

About 2-nd... The commands was "./configure && make" in freshly unpacked "movit-1.0.3" directory. points to opengl/xorg-x11/lib/

# ls -lh /usr/lib/
lrwxrwxrwx 1 root root 34 Mar 31 04:35 /usr/lib/ -> opengl/xorg-x11/lib/
Sesse (developer)
2014-03-31 15:19

No, I mean which line during compilation that fails. “make” runs hundreds of commands, and it's not clear to me which of them failed.

Most likely it starts with libtool --mode=link. Paste everything from there.
varchar (reporter)
2014-03-31 15:26

Ah, here the full log, please - [^]
Sesse (developer)
2014-03-31 15:35

Oh, I see it now; it's an issue with how GLEW works (it will be fixed with libepoxy). Please add -lGL to the end of LDLIBS in Makefile (or if you want it to survive ./configure), and try again.

This is already fixed for 1.1, since epoxy works differently.
varchar (reporter)
2014-03-31 16:46

That did the trick. Finally movit compiles an installs.

Now MLT from git fails to build with "--enable-opengl". Build log can be seen at [^]
Sesse (developer)
2014-03-31 16:52

That's weird; it should pick up the -lGLEW from the .pc file. What does the installed movit.pc file look like?
varchar (reporter)
2014-03-31 16:59

# Movit pkg-config source file.


Name: movit
Description: Movit is a library for high-quality, high-performance video filters.
Version: git
Libs: -lmovit
Libs.private: -L/usr/lib -lGLEW -lfftw3 -lm
Cflags: -I${includedir}/movit -I/usr/include/eigen3 -I/usr/include/GL
varchar (reporter)
2014-03-31 17:23

Just for some clarification: last time command that build and installs movit was with prefix - "./configure prefix=/usr && make && make install". I also recently modified MLT ebuild so now MLT configures with "--enable-kdenlive". But fails to build with same result...
Sesse (developer)
2014-03-31 19:29

Looking more closely, movit.pc is actually right here, and the issue lies with MLT. (I know the MLT people are working heavily on this kind of issue, so bear with us :-) ) But if you just want a quick fix, find src/modules/opengl/Makefile (in MLT) and add -lGLEW to the end of the line that does LDFLAGS += $(shell pkg-config --libs movit 2> /dev/null).

Sorry this has caused so much problems; you're hitting things right in the middle of a transition, and most people are probably isolated from this since they are using distribution packages.
varchar (reporter)
2014-03-31 20:21

Yes! Now it works. And greeting me with error messages:

""" QCoreApplication::postEvent: Unexpected null receiver
"[filter avcolor_space] Invalid format glsl_texture"
"[filter avcolor_space] Invalid format glsl_texture" """

Thank you for the help. And it is okay. I'm on gentoo, where readiness to fail is our power :)
Sesse (developer)
2014-03-31 20:24

That sounds like you compiled MLT without --enable-opengl --enable-gpl?
varchar (reporter)
2014-03-31 20:40

With, as for my understanding. Please take a look at portion of build log here - [^]
Sesse (developer)
2014-03-31 20:43

OK, and if you've rebuilt Kdenlive against this MLT compile (please double-check), you shouldn't get these messages.

When do they come, anyway?
varchar (reporter)
2014-03-31 21:08

I just recompiled Kdenlive after successful installs of Movit and git MLT. What additional checks required?

Errors appears just after first click on timeline or inside preview in Kdenlive window. Also preview looks strange, will attach screenshot if you want.
Sesse (developer)
2014-03-31 21:10

I just wanted to check that your Kdenlive is actually linked against the MLT you just compiled, and not an older version. You can check this with ldd on your kdenlive library.

If you still get these messages, please file a bug with MLT.
varchar (reporter)
2014-03-31 21:18

May be you mean binary? If so:

$ ldd /usr/bin/kdenlive (0x00007fff88b9a000) => /usr/lib64/ (0x00007fd11beed000) => /usr/lib64/ (0x00007fd11ba53000) => /usr/lib64/ (0x00007fd11b7dd000) => /usr/lib64/ (0x00007fd11b5ca000) => /usr/lib64/ (0x00007fd11b311000) => /usr/lib64/qt4/ (0x00007fd11b011000) => /usr/lib64/qt4/ (0x00007fd11ab6e000) => /usr/lib64/qt4/ (0x00007fd11a915000) => /usr/lib64/qt4/ (0x00007fd119c6f000) => /usr/lib64/qt4/ (0x00007fd1199f0000) => /usr/lib64/qt4/ (0x00007fd1197a9000) => /usr/lib64/qt4/ (0x00007fd1192c7000) => /lib64/ (0x00007fd1190aa000) => /usr/lib64/ (0x00007fd118e78000) => /usr/lib64/ (0x00007fd118c56000) => /usr/lib64/ (0x00007fd1189d6000) => /usr/lib64/ (0x00007fd11876a000) => /usr/lib64/ (0x00007fd11842e000) => /usr/lib64/ (0x00007fd11811c000) => /usr/lib64/ (0x00007fd117ef4000) => /usr/lib64/ (0x00007fd117a1e000) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/ (0x00007fd117717000) => /lib64/ (0x00007fd11741a000) => /lib64/ (0x00007fd11706d000) => /usr/lib64/ (0x00007fd116e65000) => /usr/lib64/ (0x00007fd116c49000) => /usr/lib64/ (0x00007fd11694f000) => /usr/lib64/qt4/ (0x00007fd116604000) => /usr/lib64/ (0x00007fd1163d0000) => /usr/lib64/ (0x00007fd1161ca000) => /usr/lib64/ (0x00007fd115fbf000) => /usr/lib64/ (0x00007fd115db9000) => /usr/lib64/ (0x00007fd115baf000) => /usr/lib64/ (0x00007fd11592c000) => /usr/lib64/ (0x00007fd1156c4000) => /usr/lib64/ (0x00007fd11540a000) => /lib64/ (0x00007fd115206000) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/ (0x00007fd114ff0000) => /lib64/ (0x00007fd114dd9000) => /usr/lib64/ (0x00007fd114aad000) => /usr/lib64/ (0x00007fd114871000) => /usr/lib64/ (0x00007fd114661000) => /usr/lib64/ (0x00007fd114457000) => /usr/lib64/ (0x00007fd11421a000) => /usr/lib64/ (0x00007fd114008000) => /usr/lib64/ (0x00007fd113dca000) => /lib64/ (0x00007fd113bc2000)
        /lib64/ (0x00007fd11c560000) => /usr/lib64/ (0x00007fd11399a000) => /usr/lib64/ (0x00007fd113797000) => /usr/lib64/ (0x00007fd113595000) => /usr/lib64/ (0x00007fd11337c000) => /usr/lib64/ (0x00007fd113177000) => /usr/lib64/ (0x00007fd112f74000) => /usr/lib64/ (0x00007fd112d71000) => /usr/lib64/ (0x00007fd112b6a000) => /usr/lib64/ (0x00007fd112949000) => /usr/lib64/ (0x00007fd112746000) => /usr/lib64/ (0x00007fd112540000) => /usr/lib64/ (0x00007fd112334000) => /usr/lib64/ (0x00007fd11203c000) => /lib64/ (0x00007fd111e2a000) => /lib64/ (0x00007fd111c25000) => /usr/lib64/ (0x00007fd1119b8000) => /usr/lib64/ (0x00007fd1115d5000) => /usr/lib64/ (0x00007fd11139d000) => /usr/lib64/ (0x00007fd111036000) => /usr/lib64/ (0x00007fd110e0b000) => /usr/lib64/ (0x00007fd110c07000) => /usr/lib64/ (0x00007fd110a01000) => /usr/lib64/ (0x00007fd11068b000) => /usr/lib64/ (0x00007fd10ef3f000)

If not, please tell me on which file I must run ldd.
Sesse (developer)
2014-03-31 21:21

This is the right file. Does /usr/lib64/ and /usr/lib64/ match the library you just compiled?
varchar (reporter)
2014-03-31 21:26

Locks like yes:..

$ ls -l /usr/lib64/ /usr/lib64/
lrwxrwxrwx 1 root root 17 Mar 31 21:35 /usr/lib64/ ->
lrwxrwxrwx 1 root root 15 Mar 31 21:35 /usr/lib64/ ->
Sesse (developer)
2014-03-31 21:33

OK, then you'll need to file a bug with MLT to figure out why this happens.
Sesse (developer)
2014-04-01 23:04

By the way, I take it that you've already run the Movit unit tests, right? "make check" should test that everything is okay with your setup.
varchar (reporter)
2014-04-01 23:25

No. Don't know about test early. Many of them fails. Attached output of "$ make check > make-check.log".
Sesse (developer)
2014-04-01 23:29

OK, there are obviously rounding/accuracy issues in either your GPU or your drivers, but basic OpenGL works. I might have asked you before, but could you paste the output of glxinfo?
varchar (reporter)
2014-04-01 23:37

Attached to the report.
Sesse (developer)
2014-04-01 23:48

OpenGL renderer string: Gallium 0.4 on AMD RV620
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.1.0

So. You are running an eight year old GPU. Using Gallium. With a driver that defaults to core profile.

I am closing this bug. Please take tech support issues on how to get a working OpenGL setup to your distribution.
varchar (reporter)
2014-04-01 23:52

This bug not about my setup. But about kdenlive future without (or with optional movit). Reopened.
ttguy (updater)
2014-05-21 16:57

version 0.9.8 is now out and it will start with out movit initialization errors. So we can probably close this.
varchar (reporter)
2014-06-04 02:34

ttguy, what? Who are yours "we"? You just, like me, reporter so... better go-go far-far away from here! Such (good and useful (no joke) ) thing (movit) may and must be optional. IMHO. Pediod. This is what this is bug about.

- Issue History
Date Modified Username Field Change
2014-03-29 00:59 varchar New Issue
2014-03-29 22:39 maverickp Note Added: 0009827
2014-03-30 03:03 Sesse Note Added: 0009832
2014-03-30 03:06 Sesse Priority high => normal
2014-03-30 03:06 Sesse Severity block => feature
2014-03-30 23:16 varchar Note Added: 0009838
2014-03-30 23:26 Sesse Note Added: 0009839
2014-03-30 23:41 varchar Note Added: 0009840
2014-03-30 23:42 Sesse Note Added: 0009841
2014-03-30 23:43 Sesse Note Edited: 0009841 View Revisions
2014-03-31 13:19 varchar Note Added: 0009845
2014-03-31 13:50 Sesse Note Added: 0009846
2014-03-31 14:48 varchar Note Added: 0009847
2014-03-31 14:51 Sesse Note Added: 0009848
2014-03-31 15:14 varchar Note Added: 0009849
2014-03-31 15:19 Sesse Note Added: 0009850
2014-03-31 15:26 varchar Note Added: 0009851
2014-03-31 15:35 Sesse Note Added: 0009852
2014-03-31 16:46 varchar Note Added: 0009853
2014-03-31 16:52 Sesse Note Added: 0009854
2014-03-31 16:59 varchar Note Added: 0009855
2014-03-31 17:23 varchar Note Added: 0009856
2014-03-31 19:29 Sesse Note Added: 0009858
2014-03-31 20:21 varchar Note Added: 0009859
2014-03-31 20:24 Sesse Note Added: 0009860
2014-03-31 20:40 varchar Note Added: 0009861
2014-03-31 20:43 Sesse Note Added: 0009862
2014-03-31 21:08 varchar Note Added: 0009863
2014-03-31 21:10 Sesse Note Added: 0009864
2014-03-31 21:18 varchar Note Added: 0009865
2014-03-31 21:21 Sesse Note Added: 0009866
2014-03-31 21:26 varchar Note Added: 0009867
2014-03-31 21:33 Sesse Note Added: 0009868
2014-04-01 23:04 Sesse Note Added: 0009887
2014-04-01 23:25 varchar File Added: make-check.log
2014-04-01 23:25 varchar Note Added: 0009888
2014-04-01 23:29 Sesse Note Added: 0009889
2014-04-01 23:33 varchar File Added: varchar-glxinfo.txt
2014-04-01 23:37 varchar Note Added: 0009890
2014-04-01 23:48 Sesse Note Added: 0009891
2014-04-01 23:49 Sesse Status new => resolved
2014-04-01 23:49 Sesse Resolution open => no change required
2014-04-01 23:52 varchar Note Added: 0009892
2014-04-01 23:52 varchar Status resolved => feedback
2014-04-01 23:52 varchar Resolution no change required => reopened
2014-05-21 16:57 ttguy Note Added: 0010057
2014-06-04 02:34 varchar Note Added: 0010068
2014-06-04 02:34 varchar Status feedback => new
2014-08-06 00:30 vpinon Status new => resolved
2014-08-06 00:30 vpinon Fixed in Version => 0.9.8
2014-08-06 00:30 vpinon Resolution reopened => suspended
2014-08-06 00:30 vpinon Assigned To => vpinon

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker