View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003245KdenliveRenderingpublic2014-03-29 16:352014-09-12 18:47
Assigned Tovpinon 
Platform64 bitOSGentoo LinuxOS Version
Product Version0.9.6 
Target VersionFixed in Version 
Summary0003245: Unneeded part of audio track appended to end of rendered zone
DescriptionVideo part of my project - PPM bitmaps.
Audio - pcm_s16le 44100 mono wav.

When I try render zone with audio some unwanted audio segment (wich was next to the zone end ) appended to the end of render. Please see screenshot where that garbage part underlined by red color.
Steps To ReproduceCreate project with PPM bitmaps as video and pcm_s16le 44100 mono wav as audio. Select zone, render it with audio, my command:

"" f=matroska acodec=pcm_s16le ac=1 frequency=44100 pix_fmt=yuv420p vcodec=libx264 qp=0 preset=ultrafast aspect=%dar ""

play it and listen unwanted audio part at the and.
TagsNo tags attached.
Build/Install Method(select)
Attached Filespng file icon wtf.png [^] (88,374 bytes) 2014-03-29 16:35

gz file icon test-prj.tar.gz [^] (426,104 bytes) 2014-03-29 23:30
? file icon flac-broken(flac-to-aac-recoded-for-size).avi [^] (149,796 bytes) 2014-04-03 10:36

- Relationships

-  Notes
varchar (reporter)
2014-03-29 17:10

>(wich was next to the zone end )
Misinformation, above - wrong. It was some other segment, not "next to the zone end". But anybody cares?..
j-b-m (administrator)
2014-03-29 22:36

Which ffmpeg / libav version are you using?
The best way to help us is if you can reproduce the problem with a very simple project (1 or 2 bitmaps + 1 audio file).

Then you can archive the project (in project > archive project > check 'compressed archive')

It will create a .tar.gz file with source clips that you can attach here or mail to me if you don't want it publicly available..

That way I can work on a fix
varchar (reporter)
2014-03-29 23:31

Attached simplified project on which I can reproduce this bug (from second attempt, hmm, first zone render was ok).

$ ffmpeg -version
ffmpeg version 2.1.3
built on Mar 12 2014 06:05:53 with gcc 4.7.3 (Gentoo 4.7.3-r1 p1.4, pie-0.5.5)
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc --cxx=x86_64-pc-linux-gnu-g++ --ar=x86_64-pc-linux-gnu-ar --optflags='-march=native -O3 -pipe' --extra-cflags='-march=native -O3 -pipe' --extra-cxxflags='-march=native -O2 -pipe' --disable-static --enable-gpl --enable-postproc --enable-avfilter --enable-avresample --disable-stripping --enable-libvidstab --enable-version3 --disable-indev=v4l2 --disable-outdev=v4l2 --disable-indev=oss --disable-indev=jack --disable-outdev=oss --enable-version3 --enable-nonfree --enable-bzlib --disable-runtime-cpudetect --disable-debug --disable-doc --disable-gnutls --disable-hardcoded-tables --enable-iconv --enable-network --disable-openssl --enable-ffplay --disable-vaapi --disable-vdpau --enable-zlib --enable-libvo-aacenc --disable-libvo-amrwbenc --enable-libmp3lame --disable-libaacplus --disable-libfaac --enable-libtheora --enable-libtwolame --disable-libwavpack --enable-libx264 --enable-libxvid --disable-libcdio --disable-libiec61883 --disable-libdc1394 --disable-libcaca --disable-openal --disable-libv4l2 --disable-libpulse --enable-x11grab --disable-libflite --disable-frei0r --disable-fontconfig --disable-ladspa --disable-libass --enable-libfreetype --disable-libsoxr --enable-pthreads --enable-libopencore-amrwb --enable-libopencore-amrnb --enable-libfdk-aac --disable-libopenjpeg --disable-libbluray --disable-libcelt --disable-libgme --disable-libgsm --disable-libmodplug --disable-libopus --disable-libquvi --disable-librtmp --disable-libssh --disable-libschroedinger --disable-libspeex --enable-libvorbis --disable-libvpx --disable-libzvbi --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-mips32r2 --disable-mipsdspr1 --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-vis --disable-amd3dnow --disable-amd3dnowext --disable-avx --disable-avx2 --disable-fma4 --disable-mmxext --disable-sse3 --disable-sse4 --disable-sse42 --cpu=host
libavutil 52. 48.101 / 52. 48.101
libavcodec 55. 39.101 / 55. 39.101
libavformat 55. 19.104 / 55. 19.104
libavdevice 55. 5.100 / 55. 5.100
libavfilter 3. 90.100 / 3. 90.100
libavresample 1. 1. 0 / 1. 1. 0
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100
varchar (reporter)
2014-04-02 13:54
edited on: 2014-04-02 13:58

Same shit with recent git! Devs, j-b-m, please be smart enough to work on basic ( primitive ) functionality at first. And when ( only when ) basic functionality will be good enough on some shader shit and other features.

j-b-m (administrator)
2014-04-02 20:18

Changing the audio codec to aac fixes the issue for me.
The problem seems to be in MLT. Trying to encode with libav with following command works:

avconv -i input.mpg -t 5 -f matroska -acodec pcm_s16le -ac 1 -ar 44100 -vcodec libx264 -qp 0 -preset ultrafast result.mkv

However the same command with melt produces broken files:

melt input.mpg out=125 -consumer avformat:test.mkv f=matroska acodec=pcm_s16le ac=1 frequency=44100 pix_fmt=yuv420p vcodec=libx264 qp=0 preset=ultrafast

If it is important for you to work with this format, you can report the bug to MLT's bugtracker.

Also, for your information, the current move to OpenGL/Movit is not about having fancy 3D effects. It brings a huge performance boost and will hopefully allow Kdenlive to do HD editing with color correction, basic effects and transitions in realtime on a standard computer.
varchar (reporter)
2014-04-03 10:20

Thank you for the tip with AAC. After couple renders of same zone it's looks like all OK with AAC. Some further experiment needed to decide if it is suitable for my work, where audio filtering (like declipper, noise gate etc) was planned at the very end. Unfortunately FLAC also broken in current MLT. Even more broken then PCM. I will attach some example.

One very importent for me question - is this with PCM audio happens at the end of clip _only_ or may be somewhere in the middle of clip, at the cuts, or somewhere else... Can I trust kdenlive and MLT and no relisten more then 10 hours of materials previously rendered with PCM audio?

As for OpenGL/Movit, - ok, good thing, maybe, but you do it in wrong way. It's IMHO that for such thing it will be better not to be mandatory, so guys with old hardware, bad drivers, and in virtual machines still be able to use kdenlive.
owo (reporter)
2014-04-03 14:24

@varchar: "so guys with old hardware, bad drivers, and in virtual machines still be able to use kdenlive."
I would like to have at least one powerful open source video editor (and do not want constantly have to squint after Lightw*rks). ;-)
varchar (reporter)
2014-04-04 02:58

>I would like to have at least one powerful open source video editor
I'm with you. But what we will have is "BUGS require GPU" video editor. Sad but true.
vpinon (administrator)
2014-04-04 23:23

Please remind that kdenlive (&MLT) are worked on by very few volunteers (2/3 people) for years, with highs & lows in motivation. Working with GPU does bring refreshing fun, so let's go with it.
BTW even with proprietary SW your old hardware is going to suffer (bye bye XP) ;-)
More seriously, I am willing to focus on stabilizing a version & making GL filters optional... But have absolutely no time these weeks (what am I doing on this tracker then? hum, back to real work :-/)
varchar (reporter)
2014-04-08 11:03

vpinon, I'm glad that you devs have some fun from movit integtation. Fun makes life longer so may be it will compensate some of the curses that I put on you every time when I try to work in kdenlive ;-)

Anyway, I'm here to try to clarificate a bit the situation with FLAC.
Figured out that FLAC does not broken as I thought before. And attached "flac-broken(flac-to-aac-recoded-for-size).avi" illustrates another bug that happens with all audio codecs at the start of project when audio track begins with some delay after video. As workaround just put some silence or muted audio segment below the video to make video and audio tracks begin at same time.
ddennedy (developer)
2014-08-30 21:41
edited on: 2014-08-30 21:43

This is a tough and interesting bug for me to reproduce. I did not find any problem specific to FLAC or having no audio at the beginning. Perhaps inserting the silence audio merely mutes the extra audio that is appended. For me (MLT dev), the problem can be detected by the duration of the output file: slightly longer than expected - as compared to equivalent file with FLAC or AAC. For me, the problem is reproduced when using pcm_s16le audio codec, a video track in the output, and threads > 0. Changing the muxer to mov or the video codec to mpeg4 did not fix it. Only removing the threads property or setting it to 0 fixed it. Furthermore, I commented out the code in MLT that handles the thread property, and it still produces a file longer than expected! It seems something strange with passing "threads" as an AVOption to libavcodec.

I do not have a fix at this time, but it would be nice if someone else can confirm this test case. First, reproduce the problem. Then, instead of doing a normal Render to File, Generate a Script. Next, edit the script, locate "threads=8" or whatever it is for you. Change it to "threads=0", run it, and check the output.

vpinon (administrator)
2014-09-12 15:03

as multithreading is now disabled, do you still reproduce the bug?
ddennedy (developer)
2014-09-12 18:47

vpinion, "threads=0" does not disable multithreading. That tells x264 to automatically determine the number of threads to use, but it should tell most (all?) audio codecs not to use threading, if any of them support it.

I investigated this some more after my last comment. When I changed the duration of my test case, I could still reproduce a problem with threads=0 or disabling any thread options on libav API. This makes me wonder if I am reproducing the bug reliably and have a good way to determine resolution of the bug. I suspect there is something going on while draining the audio samples queue and encoder at the end of output. It is still an open issue for me that I want to look into again very soon.

- Issue History
Date Modified Username Field Change
2014-03-29 16:35 varchar New Issue
2014-03-29 16:35 varchar File Added: wtf.png
2014-03-29 17:10 varchar Note Added: 0009821
2014-03-29 22:36 j-b-m Note Added: 0009826
2014-03-29 22:36 j-b-m Assigned To => j-b-m
2014-03-29 22:36 j-b-m Status new => feedback
2014-03-29 23:30 varchar File Added: 0003245-test-prj.tar.gz
2014-03-29 23:31 varchar Note Added: 0009829
2014-03-29 23:31 varchar Status feedback => assigned
2014-04-02 13:54 varchar Note Added: 0009896
2014-04-02 13:58 varchar Note Edited: 0009896 View Revisions
2014-04-02 20:18 j-b-m Note Added: 0009897
2014-04-02 20:18 j-b-m Status assigned => feedback
2014-04-03 10:20 varchar Note Added: 0009903
2014-04-03 10:20 varchar Status feedback => assigned
2014-04-03 10:36 varchar File Added: flac-broken(flac-to-aac-recoded-for-size).avi
2014-04-03 14:24 owo Note Added: 0009907
2014-04-04 02:58 varchar Note Added: 0009927
2014-04-04 23:23 vpinon Note Added: 0009930
2014-04-08 11:03 varchar Note Added: 0009961
2014-08-06 00:10 vpinon Assigned To j-b-m => vpinon
2014-08-30 21:41 ddennedy Note Added: 0010280
2014-08-30 21:43 ddennedy Note Edited: 0010280 View Revisions
2014-09-12 15:03 vpinon Note Added: 0010316
2014-09-12 15:03 vpinon Status assigned => feedback
2014-09-12 18:47 ddennedy Note Added: 0010320

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker