View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003253KdenliveMLTpublic2014-04-01 10:252014-08-06 00:00
Assigned ToSesse 
Platform64 bitOSKubuntuOS Version12.10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0003253: recent update from PPA causes crash on startup
DescriptionI noticed lot of crashing after updating kdenlive (from ppa) yesterday.
crashing happened when i dragged clips to timeline or sometimes when just scrubbing.. sometimes when i just selected a clip.

so today after updating again, lot of new versions.. lobmovit2, mlt, melt.. but now, kdenlive crashes before I see any of the interface even. everytime.

it complains about some missing debug symbols but I put here what i have from today..

oh, and all this crashing started happening after that update yesterday.. before that maybe week or so ago, everything was working just fine..
Steps To Reproducejust try to launch kdenlive
Additional InformationApplication: Kdenlive (kdenlive), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fc41c8707c0 (LWP 4467))]

Thread 5 (Thread 0x7fc3f3a10700 (LWP 4475)):
#0 0x00007fc41721bde3 in select () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fc41953bad1 in ?? () from /usr/lib/x86_64-linux-gnu/
0000002 0x00007fc41945ef2f in ?? () from /usr/lib/x86_64-linux-gnu/
0000003 0x00007fc418d7df6e in start_thread (arg=0x7fc3f3a10700) at pthread_create.c:311
0000004 0x00007fc4172239cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7fc3f2ce1700 (LWP 4509)):
#0 0x00007fc41958b812 in ?? () from /usr/lib/x86_64-linux-gnu/
#1 0x00007fc41958b8d5 in ?? () from /usr/lib/x86_64-linux-gnu/
0000002 0x00007fc4145afd4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/
0000003 0x00007fc4145b05c3 in ?? () from /lib/x86_64-linux-gnu/
0000004 0x00007fc4145b07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/
0000005 0x00007fc41958ba76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000006 0x00007fc41955d5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000007 0x00007fc41955d8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000008 0x00007fc41945c88f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/
0000009 0x00007fc41953ed13 in ?? () from /usr/lib/x86_64-linux-gnu/
0000010 0x00007fc41945ef2f in ?? () from /usr/lib/x86_64-linux-gnu/
0000011 0x00007fc418d7df6e in start_thread (arg=0x7fc3f2ce1700) at pthread_create.c:311
0000012 0x00007fc4172239cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7fc3f19b8700 (LWP 4516)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1 0x00007fc4191d33cb in mlt_consumer_rt_frame () from /usr/lib/
0000002 0x00007fc403eadf18 in ?? ()
0000003 0x00007fc418d87720 in ?? () from /lib/x86_64-linux-gnu/
0000004 0x0000000100001000 in ?? ()
0000005 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc3f11b7700 (LWP 4517)):
[KCrash Handler]
0000005 __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:235
0000006 0x00007fc404b9f47f in ?? () from /usr/lib/x86_64-linux-gnu/
0000007 0x00007fc404ba0a4c in ?? () from /usr/lib/x86_64-linux-gnu/
0000008 0x00007fc404bc6355 in ?? () from /usr/lib/x86_64-linux-gnu/
0000009 0x00007fc4048de1c3 in ?? () from /usr/lib/x86_64-linux-gnu/
0000010 0x00007fc4048dfb89 in movit::init_movit(std::string const&, movit::MovitDebugLevel) () from /usr/lib/x86_64-linux-gnu/
0000011 0x00007fc404e36793 in ?? ()
0000012 0x0000000100000001 in ?? ()
0000013 0x00000000007a1bf0 in ?? ()
0000014 0x00007fc3dc1b7c98 in ?? ()
0000015 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc41c8707c0 (LWP 4467)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1 0x00007fc41945f406 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/
0000002 0x00007fc41945eafe in QThread::wait(unsigned long) () from /usr/lib/x86_64-linux-gnu/
0000003 0x00007fc41953b5fd in ?? () from /usr/lib/x86_64-linux-gnu/
0000004 0x00007fc417165071 in __run_exit_handlers (status=1, listp=0x7fc4174ea6a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
0000005 0x00007fc4171650f5 in __GI_exit (status=<optimized out>) at exit.c:99
0000006 0x00007fc419fb56b8 in ?? () from /usr/lib/x86_64-linux-gnu/
0000007 0x00007fc41c280620 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/
0000008 0x00007fc4184e364e in _XIOError () from /usr/lib/x86_64-linux-gnu/
0000009 0x00007fc4184e17c5 in _XReply () from /usr/lib/x86_64-linux-gnu/
0000010 0x00007fc4184c8396 in XGetWindowProperty () from /usr/lib/x86_64-linux-gnu/
0000011 0x00007fc419fc46cb in ?? () from /usr/lib/x86_64-linux-gnu/
0000012 0x00007fc419fc870e in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/x86_64-linux-gnu/
0000013 0x00007fc419ff0922 in ?? () from /usr/lib/x86_64-linux-gnu/
0000014 0x00007fc4145b03b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/
0000015 0x00007fc4145b0708 in ?? () from /lib/x86_64-linux-gnu/
0000016 0x00007fc4145b07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/
0000017 0x00007fc41958ba55 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000018 0x00007fc419ff09d6 in ?? () from /usr/lib/x86_64-linux-gnu/
0000019 0x00007fc41955d5ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000020 0x00007fc41955d8e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000021 0x00007fc419562e5b in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/
0000022 0x0000000000455ac9 in main (argc=<optimized out>, argv=0x7fffa8f2fd68) at /build/buildd/kdenlive-0.9.7+git20140331.069fbd7d/src/main.cpp:93
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Filestxt file icon report1.txt [^] (12,666 bytes) 2014-04-01 10:25 [Show Content]
txt file icon report2.txt [^] (5,570 bytes) 2014-04-01 10:28 [Show Content]
txt file icon glxinfo.txt [^] (55,136 bytes) 2014-04-03 04:15 [Show Content]
txt file icon report3.txt [^] (11,052 bytes) 2014-04-03 10:00 [Show Content]
txt file icon report4.txt [^] (5,432 bytes) 2014-04-03 23:24 [Show Content]
txt file icon report5.txt [^] (20,581 bytes) 2014-04-04 01:25 [Show Content]
txt file icon gdbtrace.txt [^] (8,094 bytes) 2014-04-04 01:40 [Show Content]
txt file icon gdbtrace-fixedpaste.txt [^] (8,092 bytes) 2014-04-04 01:43 [Show Content]
jpg file icon projecttree.jpg [^] (149,763 bytes) 2014-04-05 03:41

jpg file icon timeline.jpg [^] (159,411 bytes) 2014-04-05 03:41

diff file icon makecurrent.diff [^] (907 bytes) 2014-04-05 13:40 [Show Content]
txt file icon breakpoint.txt [^] (7,288 bytes) 2014-04-14 11:24 [Show Content]
txt file icon btfull.txt [^] (7,288 bytes) 2014-04-14 11:27 [Show Content]

- Relationships

-  Notes
basse (reporter)
2014-04-01 10:30

and one more note, the instant crashing started happening when libepox0 came from the repos as a new package.
Sesse (developer)
2014-04-01 22:55

Yes, the crash is somewhere in libepoxy. The backtrace isn't that useful, though, since libepoxy is built without debug symbols.

Maybe sunab can provide a libepoxy0-dbg package? There's also been a bunch of changes to libepoxy recently, so most likely, the git version should be used instead of 1.1, if possible.
Sesse (developer)
2014-04-03 01:58

Also, it would be interesting to know which driver this is, because it will probably make reproducing it easier for the epoxy author. Do you think you could attach the output of glxinfo on your system?
basse (reporter)
2014-04-03 04:19

sure. i run dual monitor setup on a acer laptop with nvidia card.. well, it's all in the glxinfo.txt :)


basse (reporter)
2014-04-03 09:59

i compiled libepoxy from the git sources and replaced the one that comes from sunab... kdenlive starts again!...

but crashing continues. and I noticed (hope this gives any hint) something strange too: when i create new project (dvd/dv widescreen pal) and bring on a a clip it looks alright when you preview it, but if I drag it to the timeline and play from there it's not widescreen at all..
if I renderout, the final movie is correctly widescreen again.
if I change the project settings to dvd/dv widescreen ntsc the playback on timeline looks correct.. but this is wrong for my videofiles and kdenlive will complain if i bring new clips in.
so something not working in timeline? this is new behaviour, and I'm no coder but to me wouldn't be total surprise if it has something to do with kdenlive crashing all the time on playbacks and importing clips..
i'm attaching one more crash log.. and please let me know if there is something I can do to make the logs better to help out finding the bug..
Sesse (developer)
2014-04-03 10:36

I see from the backtrace what this is. Due to Nvidia performance strangeness, Movit had to change the way it is doing resource handling, and one of the upshots of that was that the application has to tell Movit whenever it's used a given OpenGL context but is about to delete that context. (Kdenlive creates lots of these temporary contexts, since it frequently creates new worker threads for various small things.)

However, Kdenlive does not yet give Movit those messages, and MLT doesn't yet have the hooks that would allow Kdenlive to do so. (This is being worked on.) What you're seeing here is, as far as I can tell, an assert complaining about a resource leak since a context wasn't properly removed.

Come to think of it, though, it is a bit strange that the EffectChain destructor tries to destroy the ResourcePool as well, since it is supposed to be shared between all instances MLT creates. (Normally this should only happen on Kdenlive shutdown.) I need to have a look at what the code is doing, assuming your MLT build is relatively recent.
basse (reporter)
2014-04-03 12:56

should be fresh.. everything comes from sunab ppa, so...
libmlt6, libmlt++3 and melt.. 0.9.1+git20140402.2af759d0-0ubuntu0~sunab~saucy1
Sesse (developer)
2014-04-03 22:29

I have a workaround for this:;a=commitdiff;h=7e8f67faedf3a0ccb299fd920cddce39694badd4 [^]

I've asked for it to be pulled into mainline MLT, which will hopefully work around the problem until we can get all the context cleanup stuff in order.
basse (reporter)
2014-04-03 23:29

ok.. well i compiled mlt from that git link...
crash still happens.. backtrace was a bit different, i attached the last bits..

(maybe it's not ok just to compile mlt alone? not sure how these library linking things go)
Sesse (developer)
2014-04-03 23:38

That's a bizarre crash. (And I doubt it's related to what you've seen before.) Basically glMapBuffer() returned NULL but didn't return an error. Returning NULL is technically allowed, but is very rare, and really indicative of a serious error somewhere.

I am suspecting this will be very hard to debug without actually having access to your machine. The good news is, of course, that my patch fixes the _other_ bug, but I doubt that's much consolation for you. :-)
basse (reporter)
2014-04-04 01:21

well it's WAY better now anyways.. no crashing on start.. and editing works a bit better. I was actually able to finish right now this one animation I needed to do.. ;)

but, yes, it crashes still.
on the konsole the last thing I see after crash is something like this:
GL error 0x502 at flat_input.cpp:67
or this:
GL error 0x502 at resample_effect.cpp:442

and right now I can reproduce this quite quickly by clicking between clip in resource window and clip in timeline couple of times.. editing in timeline works quite nicely.

Sesse (developer)
2014-04-04 01:26

Hmm, it's supposed to die when it gets a 0x502 like that. Do you think you can capture a backtrace when it happens? Ideally with gdb; do something like

gdb kdenlive
break abort
<wait for it to crash>
bt full

My guess is that you don't have a valid GL context in that thread (Nvidia is a lot more picky on it than Mesa is, and there have been bugs on this in the past).
basse (reporter)
2014-04-04 01:28

i added this last resample_effect.cpp crash backlog if it's for any help.
i'll check tomorrow if there is something i can do about my nvidia drivers or something to test.. only thing i tried now was turning kde desktop effects on/off and using only one monitor and things like that.. didn't help really..
Sesse (developer)
2014-04-04 01:33

Thanks for the backtrace. It is called from a function that does have an OpenGL context correctly set up, so that's not it. Second theory: Context sharing is not working correctly, ie. some context somewhere was created without sharing with the main context. That would explain why binding to textures causes problems, too.
basse (reporter)
2014-04-04 01:36

well let's see.. and yes, sometimes it just dies and I dont even get drkonqi.. but let's try gdb
Sesse (developer)
2014-04-04 02:14

As an aside, I find it interesting that your thread 2 is actually doing GL stuff (binding to an FBO) at the same time as your error. Don't know if it's related.
Sesse (developer)
2014-04-05 02:45

Another issue is that we should probably have a mutex protecting Render::m_renderThreadGLContexts in case multiple threads are starting or stopping at the same time. But this is a small issue, and I'm not really sure whether this can happen anyway.

By the way, you're not using multiple rendering threads, are you? (For a quick check, try removing or moving away ~/.kde/share/config/kdenliverc; if it helps, this might be it.)
basse (reporter)
2014-04-05 03:40

tried removing the kdenliverc... still got crash, BUT I noticed something, don't know if that's related..
kdenlive seems confused about what aspect ratio to play on timeline, and uses what is set as default. because after I removed config file kdenlive asked me all those default settings on first start, and this time I chose widescreen preset (i used to have normal 4:3)
so now, my widescreen projects run quite nicely, and correct aspect ratio on timeline playback (used to show 4:3)..
didn't even get a crash, so I opened the other 4:3 project I had and how about that.. it was playing widescreen on timeline, ... (again correct aspect ratio if I previewed clip straight from project tree window)
so this used to be the otherway around, almost like it just wants to use whatever i set as default and not what is project settings.. funny thing is, everything renders out correctly..
i attach couple of pictures ...
basse (reporter)
2014-04-05 03:43

btw.. very nice filters those new movit ones.. I already used vignette and glow and color correction.. and MAN they are fast..!
Sesse (developer)
2014-04-05 11:57

I think the aspect bug is a separate bug, and you should probably report it as such. :-)

I had a gdb session, and I couldn't find anything wrong with the context sharing on my machine. (Too bad, it would have explained all of your issues very nicely.) I think this is rapidly approaching the point where unfortunately, I cannot figure this out without actually having access to your machine (or another with the same issue), and I suppose you're not in Zürich, Oslo, Hamar, Reykjavik or Seattle :-)

We can do a last-ditch attempt to see if we can find anything wrong with the sharing, if you're happy with doing weird gdb tricks. If you could do

gdb kdenlive
(gdb) break 'QGLWidget::QGLWidget(QWidget*, QGLWidget const*, QFlags<Qt::WindowType>)'
Breakpoint 1 at 0x44cd50 (2 locations)
(gdb) set height 0
(gdb) commands 1
Type commands for breakpoint(s) 1, one per line.
End with a line saying just "end".
>printf "New GLWidget %p, sharing with %p\n", $rdi, $rdx
(gdb) r

Then reproduce the error and send the output log. The idea is if we can somehow find a GLWidget that's not set up to share properly with an existing one (except the very first one, of course).

But I'm not that optimistic, I have to say :-)
Sesse (developer)
2014-04-05 13:41

Oh, and if you could also try makecurrent.diff which I just uploaded. It might actually be relevant here.
basse (reporter)
2014-04-05 18:39

weirdest thing.. i'm trying this gdb trick you showed, but can't make it crash now?! i'll try again tomorrow, running out of time now.. strange..
sunab (developer)
2014-04-07 07:41

Packages updated, libepoxy is now tracking git head with -dbg package enabled to follow sesse's advice. Hope it helps.
Sesse (developer)
2014-04-12 02:54

Basse, what's the status of this bug for you?
Sesse (developer)
2014-04-12 16:00

I tried Kdenlive an NVIDIA machine (although with a very old card; a GT210), and although for some reason, Movit transitions didn't work (maybe something with my compile?), I could not reproduce this.
norms2 (reporter)
2014-04-13 12:12

sesse, with regard to your last Note. My integated HD Radeon 240 would not work with Movit. I was given a GT240 to try and the Movit effects now worked, but not the transitions (tried dissolve). Found out that my card most likely had openGL 1.2. and that decent implementation didn't appear until version 2.0.
Purchased a new graphics card which said openGL 4.1 and now your Dissolve transition works fine.
Sesse (developer)
2014-04-13 12:19

The transitions are broken for me too, unfortunately, and I don't have the time to look into it right now. (I'm surprised it worked at all on your newer card, actually.) I was more curious as of whether it had stopped crashing for you.
norms2 (reporter)
2014-04-13 13:38
edited on: 2014-04-13 13:43

Oh why, oh why does something work one day and not the next. You have to laugh. It was definitely the GLSL I was using because I was playing with the mix levels. All other effects work well for me except the "Position and Size(GLSL)" It bombs out immediately if timeline cursor is over it when adding the effect, but will show if cursor is not over the clip. No keyframe, so add one at start, adjust size and it now plays but soon crashes. Might have to open another Issue. I have a desktop plastered with crash reports on this.

Sesse (developer)
2014-04-13 13:43

Why something works one day and not the next? Well, because you are using development snapshots...?
basse (reporter)
2014-04-14 11:12

hi, sorry been busy with otherstuff.. but just updated packages again, and tried.. it starts, but the preview for timeline is even more distorted than before (not only wrong aspect ratio, but it's offsetted on bottom corner and very small and slow)

dr konqi refused to start, this is only thing i got now..
[basse@kone] ~ $ kdenlive
[mp3 @ 0x383bbe0] max_analyze_duration reached
[mp3 @ 0x383bbe0] Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x384e120] max_analyze_duration reached
[mp3 @ 0x384e120] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x35d1660] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x35d3720] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x35d3c60] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x356fa60] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x3570a80] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x35a5b40] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x3591500] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x357abe0] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x357d1a0] Estimating duration from bitrate, this may be inaccurate
kdenlive(24853) Render::checkMaxThreads: // TRACTOR PROBLEM
[dv @ 0x7f246c1bcb60] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f246c1bdd80] Estimating duration from bitrate, this may be inaccurate
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id: 0x6800185
[dv @ 0x7f246c1c4080] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f246c278480] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f246c1d98a0] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f246c1da920] Estimating duration from bitrate, this may be inaccurate
[swscaler @ 0x7f246c1c4f80] Warning: data is not aligned! This can lead to a speedloss
[dv @ 0x3fed1e0] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x42aeec0] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x42a2160] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f245c1b6080] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f245c1b68e0] Estimating duration from bitrate, this may be inaccurate
[dv @ 0x7f245c1b8760] Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x7f242c1bfcc0] max_analyze_duration reached
[mp3 @ 0x7f242c1bfcc0] Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x7f242c20e5a0] max_analyze_duration reached
[mp3 @ 0x7f242c20e5a0] Estimating duration from bitrate, this may be inaccurate
GL error 0x501 at filter_glsl_manager.cpp:442
kdenlive: Fatal IO error: client killed
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
Unable to start Dr. Konqi
basse (reporter)
2014-04-14 11:18

here is one i got from running it from gdb...
(gdb) bt
#0 0x00007ffff2b5df77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007ffff2b615e8 in __GI_abort () at abort.c:90
0000002 0x00007fffdfbc68ee in GlslManager::render_frame_rgba(movit::EffectChain*, mlt_frame_s*, int, int, unsigned char**) () from /usr/lib/mlt/
0000003 0x00007fffdfbc73d9 in ?? () from /usr/lib/mlt/
0000004 0x00007fffdfbc8d08 in ?? () from /usr/lib/mlt/
0000005 0x00007ffff48f340f in mlt_frame_get_image () from /usr/lib/
0000006 0x00007fffdace3713 in ?? () from /usr/lib/mlt/
0000007 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000008 0x00007fffdfdd7c71 in ?? () from /usr/lib/mlt/
0000009 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000010 0x00007fffdc4e7066 in ?? () from /usr/lib/mlt/
0000011 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000012 0x00007fffdc4e59fb in ?? () from /usr/lib/mlt/
0000013 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000014 0x00007fffdc4e60c7 in ?? () from /usr/lib/mlt/
0000015 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000016 0x00007fffdc4e6a4f in ?? () from /usr/lib/mlt/
0000017 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000018 0x00007fffdc4e75a6 in ?? () from /usr/lib/mlt/
0000019 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000020 0x00007ffff49088dd in ?? () from /usr/lib/
0000021 0x00007ffff48f32e7 in mlt_frame_get_image () from /usr/lib/
0000022 0x00007ffff46d9450 in Mlt::Frame::get_image(mlt_image_format&, int&, int&, int) () from /usr/lib/
0000023 0x00000000007021d1 in Render::showFrame (this=0x1712cd0, frame=0x7fff7c348d80) at /build/buildd/kdenlive-0.9.7+git20140413.c9e15915/src/renderer.cpp:1918
0000024 0x0000000000710b6c in Render::qt_static_metacall (_o=0x1712cd0, _id=25077, _a=0x7fff7c3488b0, _c=<optimized out>)
    at /build/buildd/kdenlive-0.9.7+git20140413.c9e15915/build/src/renderer.moc:148
0000025 0x00007ffff4ca9dce in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/
0000026 0x00007ffff5681dfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/
0000027 0x00007ffff5688470 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/
0000028 0x00007ffff79b4a6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/
0000029 0x00007ffff4c918bd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/
0000030 0x00007ffff4c94e1f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/
0000031 0x00007ffff4cbf073 in ?? () from /usr/lib/x86_64-linux-gnu/
0000032 0x00007fffefce33b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/
0000033 0x00007fffefce3708 in ?? () from /lib/x86_64-linux-gnu/
0000034 0x00007fffefce37ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/
0000035 0x00007ffff4cbea55 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000036 0x00007ffff57239d6 in ?? () from /usr/lib/x86_64-linux-gnu/
0000037 0x00007ffff4c905ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000038 0x00007ffff4c908e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/
0000039 0x00007ffff4c95e5b in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/
0000040 0x0000000000455ca9 in main (argc=<optimized out>, argv=0x7fffffffde58) at /build/buildd/kdenlive-0.9.7+git20140413.c9e15915/src/main.cpp:93
basse (reporter)
2014-04-14 11:26

i also managed to get it crash with that gdb breakpoint trick you showed, i attached the gdb output and backtrace (full) for that one.

- Issue History
Date Modified Username Field Change
2014-04-01 10:25 basse New Issue
2014-04-01 10:25 basse File Added: report1.txt
2014-04-01 10:28 basse File Added: report2.txt
2014-04-01 10:30 basse Note Added: 0009875
2014-04-01 22:55 Sesse Note Added: 0009886
2014-04-01 23:08 Sesse Assigned To => Sesse
2014-04-01 23:08 Sesse Status new => assigned
2014-04-03 01:58 Sesse Note Added: 0009899
2014-04-03 04:15 basse File Added: glxinfo.txt
2014-04-03 04:19 basse Note Added: 0009900
2014-04-03 09:59 basse Note Added: 0009902
2014-04-03 10:00 basse File Added: report3.txt
2014-04-03 10:36 Sesse Note Added: 0009905
2014-04-03 12:56 basse Note Added: 0009906
2014-04-03 22:29 Sesse Note Added: 0009911
2014-04-03 23:24 basse File Added: report4.txt
2014-04-03 23:29 basse Note Added: 0009914
2014-04-03 23:38 Sesse Note Added: 0009915
2014-04-04 01:21 basse Note Added: 0009920
2014-04-04 01:25 basse File Added: report5.txt
2014-04-04 01:26 Sesse Note Added: 0009921
2014-04-04 01:28 basse Note Added: 0009922
2014-04-04 01:33 Sesse Note Added: 0009923
2014-04-04 01:36 basse Note Added: 0009924
2014-04-04 01:40 basse File Added: gdbtrace.txt
2014-04-04 01:43 basse File Added: gdbtrace-fixedpaste.txt
2014-04-04 02:14 Sesse Note Added: 0009926
2014-04-05 02:45 Sesse Note Added: 0009935
2014-04-05 03:40 basse Note Added: 0009937
2014-04-05 03:41 basse File Added: projecttree.jpg
2014-04-05 03:41 basse File Added: timeline.jpg
2014-04-05 03:43 basse Note Added: 0009938
2014-04-05 11:57 Sesse Note Added: 0009939
2014-04-05 13:40 Sesse File Added: makecurrent.diff
2014-04-05 13:41 Sesse Note Added: 0009940
2014-04-05 18:39 basse Note Added: 0009941
2014-04-07 07:41 sunab Note Added: 0009948
2014-04-12 02:54 Sesse Note Added: 0009980
2014-04-12 16:00 Sesse Note Added: 0009982
2014-04-12 16:00 Sesse Status assigned => feedback
2014-04-13 12:12 norms2 Note Added: 0009984
2014-04-13 12:19 Sesse Note Added: 0009985
2014-04-13 13:38 norms2 Note Added: 0009986
2014-04-13 13:43 norms2 Note Edited: 0009986 View Revisions
2014-04-13 13:43 Sesse Note Added: 0009987
2014-04-14 11:12 basse Note Added: 0009988
2014-04-14 11:12 basse Status feedback => assigned
2014-04-14 11:18 basse Note Added: 0009989
2014-04-14 11:24 basse File Added: breakpoint.txt
2014-04-14 11:26 basse Note Added: 0009990
2014-04-14 11:27 basse File Added: btfull.txt
2014-08-06 00:00 vpinon Status assigned => resolved
2014-08-06 00:00 vpinon Resolution open => suspended

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker