View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000588KdenliveRenderingpublic2009-01-17 15:552010-01-24 01:11
Assigned Toddennedy 
PlatformOSOS Version
Product Version0.7.1 
Target VersionFixed in Version 
Summary0000588: 1GB video file plays only 8 seconds
DescriptionOne file from a DVD has the size of aroung 1GB.
Adding this file to a kdenlive project it only plays 8 seconds, where exactly the same file played via Avidemux plays around 50 minutes.
Additional InformationI obtained the version from
deb [^] intrepid main.
Which additional information do the developers need?
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships
related to 0000436assignedddennedy Some TS clips are show to be 10 minutes long whatever their real length 
has duplicate 0000774feedbackddennedy .vob file playback ok for a while then BLACK screen 

-  Notes
nowede (reporter)
2009-01-17 16:07

Maybe the clip properties are important:
length: 00:00:08:19
size 0 B (!!!)

Videocodec: MPEG-2 video
framesize: 720 x576
repeat frequence: 25.000000
pixel-side relation 1.0666667

Audiocodec: ATSC A/52A (AC-3)
channels 2
frequence: 48000
ddennedy (developer)
2009-01-27 08:15

How did you rip the DVD?
I have been able to load rips created from dvdbackup just fine.
nowede (reporter)
2009-01-27 09:06

I mounted the DVD and copied it. One of the resulting files called VTS_01_1.VOB showed that behaviour.
I also used dd to get the first 50MB of that file. It showed the same behaviour and played only a few seconds, where that part with Avidemux played as long as expected.
The dvd is a recording from German television. If it helps and you are interested, I can provide a link to the 50 MB part of the file.
ddennedy (developer)
2009-01-28 03:18

We do not use avidemux's code for reading and decoding files. We use the FFmpeg libs. Can you play the file with ffplay?
What does 'ffmpeg -i VTS_01_1.VOB' show?
If it plays in ffplay, then post a link to the file. Otherwise, you should pursue the issue with the ffmpeg tracker: [^]
nowede (reporter)
2009-01-28 08:01

ffplay VTS_01_1.VOB shows the video in the correct length - but without audio.

ffmpeg -i VTS_01_1.VOB
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Jul 23 2008 22:38:24, gcc: 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
Input #0, mpeg, from 'VTS_01_1.VOB':
  Duration: 00:00:20.6, start: 0.187389, bitrate: 20281 kb/s
  Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x576, 9500 kb/s, 25.00 fps(r)
  Stream #0.1[0x80]: Audio: 0x0000, 48000 Hz, stereo, 256 kb/s

The duration here is said to be 00:00:20.6. It should be about 3 minutes.

You can download the video from [^]
ddennedy (developer)
2009-01-28 19:58

We have some other files like this where ffmpeg is unable to determine the duration from an initial probe, but it is able to play back the entire duration. However, MLT and kdenlive are not simple players and need to know the duration. I have been looking into ways to improve the situation.
nowede (reporter)
2009-02-21 16:20

With the new version the video sequence above still only plays 21 seconds. Remarkable: cutting the last frame at the end of the sequence makes kdenlive (or ffmpeg?) discover the correct length and the video is shown in that length.
jsager33 (reporter)
2010-01-23 23:46

I'm not sure if this issue has been beaten to death. This is my first bug report so please go easy on me. I have a Sony DCR-DVD100 Handycam that writes directly to 1.4G DVD discs. After I have recorded the video and finalized the disc, it is playable in a DVD player. I use dvd::rip to rip each chapter of the DVD to its own vob file. When loading the vob's into kdenlive it reports their length to be a matter of a few seconds or so. I ran ffmpeg -i on the file and this is what I get:

FFmpeg version SVN-r20373, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  built on Jan 16 2010 19:07:30 with gcc 4.4.2
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --enable-static --enable-shared --cc=x86_64-pc-linux-gnu-gcc --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libx264 --enable-libxvid --enable-libdc1394 --disable-indev=oss --disable-outdev=oss --enable-x11grab --enable-pthreads --enable-libfaad --enable-libspeex --enable-libgsm --enable-libfaac --enable-nonfree --disable-altivec --cpu=x86-64 --enable-gpl --enable-version3 --enable-postproc --enable-avfilter --enable-avfilter-lavf --disable-stripping --enable-hardcoded-tables
  libavutil 50. 3. 0 / 50. 3. 0
  libavcodec 52.37. 1 / 52.37. 1
  libavformat 52.39. 2 / 52.39. 2
  libavdevice 52. 2. 0 / 52. 2. 0
  libavfilter 1. 4. 1 / 1. 4. 1
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0
[mpeg @ 0x6263c0]max_analyze_duration reached

Seems stream 0 codec frame rate differs from container frame rate: 59.94 (60000/1001) -> 29.97 (30000/1001)
Input #0, mpeg, from 'tessie10-001.vob':
  Duration: 00:00:07.12, start: 0.119756, bitrate: 16023 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 704x480 [PAR 10:11 DAR 4:3], 9300 kb/s, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0.1[0x80]: Audio: ac3, 48000 Hz, stereo, s16, 256 kb/s
At least one output file must be specified

As a frame of reference, avidemux reports the length as 13.346 seconds. As a workaround, I re-mux the video and audio in the vob file to and mpg file using avidemux and it loads into kdenlive perfectly. Hopefully this post will be helpful.

p.s. I am using the latest svn trunk version (0.7.7).
ddennedy (developer)
2010-01-23 23:58

jsager33, would you please load the original rip into kdenlive, right-click it in the Project Tree and choose Transcode/Remux MPEG-2. Enable the checkbox to "Add clip to project." Did the transcoded result give the correct duration in Kdenlive?
jsager33 (reporter)
2010-01-24 01:11

I did as you requested and the transcoded file gave the correct duration. I also tried the transcode with a few other clips and each transcoded clip gave the correct duration. Please let me know if there is anything more I can assist with.

btw - great app!

- Issue History
Date Modified Username Field Change
2009-01-17 15:55 nowede New Issue
2009-01-17 15:55 nowede Build/Install Method => 3rd party package
2009-01-17 16:07 nowede Note Added: 0002159
2009-01-27 08:15 ddennedy Note Added: 0002222
2009-01-27 08:15 ddennedy Status new => feedback
2009-01-27 09:06 nowede Note Added: 0002223
2009-01-28 03:18 ddennedy Note Added: 0002264
2009-01-28 08:01 nowede Note Added: 0002267
2009-01-28 19:51 ddennedy Status feedback => assigned
2009-01-28 19:51 ddennedy Assigned To => ddennedy
2009-01-28 19:58 ddennedy Note Added: 0002272
2009-01-28 19:58 ddennedy Relationship added related to 0000436
2009-02-21 16:20 nowede Note Added: 0002444
2009-10-13 07:08 ddennedy Relationship added has duplicate 0000774
2010-01-23 23:46 jsager33 Note Added: 0004568
2010-01-23 23:58 ddennedy Note Added: 0004569
2010-01-24 01:11 jsager33 Note Added: 0004573

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker