View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000061KdenliveRenderingpublic2007-12-30 23:552008-10-14 15:13
Assigned To 
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000061: Rendering aborts before 100% with no error message and rendered video is corrupt near end
DescriptionI have a slide show of about 23 minutes, with various transitions between 6-second picture clips plus occasional titles. When exporting, progress goes up to 85% then ends without any kind of error message. The resulting video is ok until 82% of the total project duration, where a transition displays psychedelic colors instead of the expected image. After that, one can see the following transition, although it is followed by psychedelic colors again. The video length is 20'30", roughly equal to 85% of the project duration. Tried with export to DVD and Mpeg-4, same results. Cutting the first 1'30" of the slideshow and regenerating gives the same bug, only at 19'28", on another transition of course (as 19'30+1'30=21'00, not 20'30). Total number of transitions at bug point is about 290, with about 244 between the two main video tracks.
Additional InformationKdenlive v 0.5 on a Mandriva 2008/i586.
Quirky transition (normally a radial sweep) shown in enclosed image (center blurred for privacy reasons)--of course, normally there *should* be some meaningful image outside the circle boundary.
TagsNo tags attached.
Build/Install Method
Attached Filespng file icon bug-1.png [^] (332,744 bytes) 2007-12-30 23:55
? file icon bug-2.avi [^] (1,159,012 bytes) 2008-01-01 14:11

- Relationships

-  Notes
administrator (administrator)
2007-12-31 14:01

Does the video plays fine in the preview monitor or can you also see the bug ? If the problem only happens on export, that might be a bug in FFmpeg. Which FFmpeg version are you using ?
aaribaud (reporter)
2007-12-31 14:48
edited on: 2008-01-01 12:48

Video plays fine in the preview monitor. The ffmpeg I'm using is, according to the RPMs, version 0.4.9-3.pre1.8994:

(EDIT: the RPMs mentioned were not from the machine where kdenlive runs, although the ffmpeg version was the same)


FYI and FWIW, the MLT versions are:


Note: I've tried to sort out the exact conditions to trigger the bug, but so far I haven't found a clear root case. I've stripped the slideshow down to only two tracks, with pictures alternating between tracks and one transition for each pair of pictures, and it still happens.

aaribaud (reporter)
2008-01-01 13:55

(incidentally, I tested with an alternate RPM of libffmpeg, namely libffmpeg51-0.4.9-3.pre1.8994.2mdv2008.0, same results.)

Important note:

Past the point where the bug occurs, one can still hear the music and discern transitions, only they are between images similar to the one partly appearing in bug-1.png, then after 7 or so of these transition, a text clip fades in then out, as specified in the project (then after a couple of seconds, the video ends).

That seems to imply that libffmpeg isn't responsible for the bug: the bug happens in the 'mixdown' of the video tracks in kdenlive, before libffmeg receives the frames for encoding to the chosen format.

Trying to attach the buggy section of the output, transcoded to mpeg-4 to save space. If/when this attachment is useless, don't hesitate to remove it.
pguerreiro (reporter)
2008-01-12 00:01

I too have this problem, the export just stops during the dvd's creation, mentioning that the file may be corrupt. All that I have left is a 1gb movie.vob. As far as i know, this file need to be less than 1gb, could it be that this error happens when kdenlive is creating the others vob's files?

I'm using kdenlive v0.5 instaled with Synaptic in Kubuntu 7.10.
steletch (reporter)
2008-01-14 15:08

I've also the same problem under mandriva (64 bits edition) with kdenlive 0.5x (no precise version by memory but not the svn one) and i've found out one case where it fails and one where it does not :-).

My input is from a dv cam with 720x576 resolution (Canon MX4i). Everytime i try to render the video at this resolution (be it using mpeg4 low/medium/high, xvid low/medium/high or dvd), this fails.

If i render _the same setup_ with another resolution (hdv_25p, 640*480, whatever the quality) i have no problem (in fact mplayer complains about not being able to sync mad frames).

It seems the rendering in the same quality than the source (i.e. 720x576 rendered in 720x576) is the culprit of the bug. So far i've not been deep in the code, but i hope this will help in triggering the problem.
aaribaud (reporter)
2008-01-17 21:40

Re: steletch's comment

I've tried rendering in CIF rather than DVD size: bug happened exactly the same way, so steletch seems to be having a different issue.
madsdyd (administrator)
2008-10-14 15:13

It appears this bug was filed against the KDE3/qt3 version of Kdenlive. Due to a shortage of developers, this version is no longer supported (see [^]), and this issue has been closed.

If you believe this is an error, or can reproduce this issue using the KDE4/qt4 version of Kdenlive, please file a new report.

If you have trouble building/obtaining the KDE4/qt4 version of Kdenlive, please consult [^]

You may especially be interessted in the Kdenlive Builder Wizard, available at [^] .

Note, that you do not need to run KDE4 to build and run the Kdenlive KDE4 version.

- Issue History
Date Modified Username Field Change
2007-12-30 23:55 aaribaud New Issue
2007-12-30 23:55 aaribaud File Added: bug-1.png
2007-12-31 14:01 administrator Note Added: 0000121
2007-12-31 14:48 aaribaud Note Added: 0000122
2008-01-01 12:48 aaribaud Note Edited: 0000122
2008-01-01 13:55 aaribaud Note Added: 0000123
2008-01-01 14:11 aaribaud File Added: bug-2.avi
2008-01-12 00:01 pguerreiro Note Added: 0000129
2008-01-14 15:08 steletch Note Added: 0000130
2008-01-17 21:40 aaribaud Note Added: 0000135
2008-10-14 15:13 madsdyd Note Added: 0000402
2008-10-14 15:13 madsdyd Status new => closed
2008-10-14 15:13 madsdyd Resolution open => won't fix

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker