View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000923KdenliveUser Interfacepublic2009-06-17 21:462010-09-14 23:01
Assigned ToGranjow 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.8 
Summary0000923: Timeline: All changes are rejected
DescriptionOccurs here after resizing and moving clips. Random. No way to reproduce.

When this happens, I can move a clip and it jumps back to its original position, or I can resize one and it immediately gets its original size back.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
xzhayon (developer)
2009-06-17 22:03

does an error message appear in the left bottom status bar?
Granjow (developer)
2009-06-17 22:04

Oh. I didn't take a look at it. Will report if error occurs again.

Wait, isn't there this «lock track» feature? I'm not using it, but it feels like that.
Granjow (developer)
2009-06-17 22:09

Yeah here it is!

«Cannot move clip to position %s.» (with %s replaced by the position)
I just had another clip at this position. I'll save and exit now … saving worked, exiting made kdenlive crash.

Reloading: All looks the same way it did after saving. So this time _no_ synchronization problem (timeline vs real).
Granjow (developer)
2009-06-17 22:42

Same with resize/delete. Delete action is added in the action log! Save button remains inactive if you saved before.

Yes, I'm saving after every click.
administrator (administrator)
2009-06-17 22:46

The "track locking" feature is activated through the small "lock" icon on the left of the track number, and when activated, the track is colored in light red, so you can't miss it.

I added a few safety checks that hopefully might reduce the problem you encounter (clips that cannot be moved / resized anymore), please let me know if you still get that issue when working on a project...
Granjow (developer)
2010-08-30 20:08

Marking as resolved. Didn't see this error anymore for a long time now since (so I'll see it right after closing this bug :P).

- Issue History
Date Modified Username Field Change
2009-06-17 21:46 Granjow New Issue
2009-06-17 21:46 Granjow Build/Install Method => Manual build from SVN
2009-06-17 22:03 xzhayon Note Added: 0003257
2009-06-17 22:03 xzhayon Status new => feedback
2009-06-17 22:04 Granjow Note Added: 0003258
2009-06-17 22:09 Granjow Note Added: 0003259
2009-06-17 22:42 Granjow Note Added: 0003265
2009-06-17 22:46 administrator Note Added: 0003267
2009-06-19 02:28 xzhayon Target Version => future version
2009-06-26 21:13 administrator Target Version future version => 0.7.5
2010-08-30 20:08 Granjow Note Added: 0005708
2010-08-30 20:08 Granjow Status feedback => new
2010-08-30 20:08 Granjow Status new => resolved
2010-08-30 20:08 Granjow Fixed in Version => Recent git
2010-08-30 20:08 Granjow Resolution open => fixed
2010-08-30 20:08 Granjow Assigned To => Granjow
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed

Copyright © 2000 - 2016 MantisBT Team
Powered by Mantis Bugtracker